Resetting efxs ports?

Unanswered Question
Jan 24th, 2008

Customers got CME and what appears to be a hung virtual voice-port…. As you can see from the ephone debug below they've got a 7941 with 2 lines, both receive calls fine but when they try to seize the main DN it doesn't get dial tone and won't call out whereas the second line does…. Prior to running this debug I got them to swap the phone out so it's deffo a fault on the DN, the main problem I've got is accessing the individual port “voice-port 50/0/3.1” won't take even tho the IOS command help suggests it does! As a nearly last resort I reset the main voice-port but even that hasn't cleared the fault! Strange.. anyone know how to reset this on it's own before I think about rebooting the CME!

The debug simply shows both lines being seized….. and there are no live calls on the system to match this!

Dead Outgoing Line (602)


Jan 24 08:55:58.460: ephone-59[24]:SkinnyRestartTransferCollect for line 0 chan


Jan 24 08:55:58.460: ephone-59[24]:SkinnyRestartTransferCollect ignored

Jan 24 08:55:58.460: ephone-59[24]:SpeakerPhoneOffHook

Jan 24 08:55:58.460: ephone-59[24]:OFFHOOK

Jan 24 08:55:58.460: ephone-59[24]:---SkinnySyncPhoneDnOverlays has activeLine

current DN 3

Jan 24 08:55:58.460: ephone-59[24]:SIEZE on activeLine 1 activeChan 1

Jan 24 08:55:58.464: ephone-59[24]:SetCallState line 1 DN 3(-1) chan 1 ref 3380


Jan 24 08:55:58.464: ephone-59[24]:Check Plar Number

Jan 24 08:55:58.464: efxs_onhook_offhook: call is already reserved on htsp 50/0/3.1 cdb 0x0

Jan 24 08:56:23.476: %ISDN-6-DISCONNECT: Interface Serial0/0/0:1 disconnected

rom 7791752722 , call lasted 265 seconds

working line 2 (601)

Elizabethan-CCME#term mon


Jan 24 08:55:33.100: %ISDN-6-DISCONNECT: Interface Serial0/0/0:3 disconnected f

rom 1777869503 , call lasted 76 seconds

Jan 24 08:55:36.872: ephone-59[24]:SkinnyRestartTransferCollect for line 0 chan


Jan 24 08:55:36.872: ephone-59[24]:SkinnyRestartTransferCollect ignored

Jan 24 08:55:36.876: ephone-59[24]:SpeakerPhoneOffHook

Jan 24 08:55:36.876: ephone-59[24]:OFFHOOK

Jan 24 08:55:36.876: ephone-59[24]:---SkinnySyncPhoneDnOverlays has activeLine 2

current DN 2

Jan 24 08:55:36.876: ephone-59[24]:SIEZE on activeLine 2 activeChan 1

Jan 24 08:55:36.876: ephone-59[24]:SetCallState line 2 DN 2(-1) chan 1 ref 33801


Jan 24 08:55:36.876: ephone-59[24]:Check Plar Number

Jan 24 08:55:36.880: DN 2 chan 1 Voice_Mode

Jan 24 08:55:36.880: dn_tone_control DN=2 chan 1 tonetype=33:DtInsideDialTone on

off=1 pid=227

Jan 24 08:55:46.880: dn_tone_control DN=2 chan 1 tonetype=0:DtSilence onoff=0 pi


Jan 24 08:55:46.880: dn_tone_control DN=2 chan 1 tonetype=37:DtReorderTone onoff

=1 pid=227

Jan 24 08:55:46.880: ephone-59[24]:DN 2 disc reason 16 normal state SIEZE

Jan 24 08:55:49.256: ephone-59[24]:ONHOOK (from phone msgID=7)

Jan 24 08:55:49.256: DN 2 chan 1 End Voice_Mode

Jan 24 08:55:49.260: ephone-59[24]:SetCallState line 2 DN 2(-1) chan 1 ref 33801


Jan 24 08:55:49.260: ephone-59[24]:SpeakerPhoneOnHook

Jan 24 08:55:49.260: ephone-59[24]:---SkinnySyncPhoneDnOverlays is onhook

Jan 24 08:55:49.260: ephone-59[24]:SpeakerPhoneOnHook

Jan 24 08:55:49.272: dn_tone_control DN=2 chan 1 tonetype=0:DtSilence onoff=0 pi


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
Paolo Bevilacqua Thu, 01/24/2008 - 04:40

Hi, which exact IOS do you have ?

Issues like that are software bugs and should be corrected in latest images.

wdejulio312 Sat, 11/05/2011 - 02:23

Has anyone fixed this issue?  I am having the same issue :

Cisco IOS Software, UC500 Software (UC500-ADVIPSERVICESK9-M), Version 15.1(2)T2, RELEASE SOFTWARE (fc1)

Technical Support:

Copyright (c) 1986-2010 by Cisco Systems, Inc.

Compiled Sat 23-Oct-10 08:04 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)XA, RELEASE SOFTWARE (fc1)

System image file is "flash:/uc500-advipservicesk9-mz.151-2.T2"

Last reload type: Normal Reload

Cisco UC560-T1E1-K9 (MPC8378) processor (revision 0x100) with 511180K/13108K bytes of memory.

48 User Licenses

4 Gigabit Ethernet interfaces

24 Serial interfaces

2 terminal lines

1 Channelized T1/PRI port

1 Virtual Private Network (VPN) Module

4 Voice FXO interfaces

4 Voice FXS interfaces

1 Voice MoH interface

1 cisco service engine(s)

256K bytes of non-volatile configuration memory.

254464K bytes of ATA CompactFlash (Read/Write)

One channel is active on the DN OCTO-LINE...  then if I want to go offhook on the .2 channel it gives me this error:

120327: Nov  5 04:15:21 CDT: efxs_onhook_offhook: call is already reserved on htsp 50/0/1.2 cdb 0x0EFXS_Glare waits E_HTSP_SETUP_REQ timeout !!

This prohibts call transfer from this DN.  New calls from the PRI come in but can only get put on hold.

Please help.



MARK BAKER Mon, 03/05/2012 - 12:11

Has anyone figured out now to reset the hung efxs port? I put in a work-a-round by removing the number from the ephone-dn and putting it on a new one and using the new ephone-dn on the ephone. I first tried to delete the DN and was going to re-add it, but I can't delete it because it says there is an active call on it.


Paolo Bevilacqua Mon, 03/05/2012 - 20:52

There is no published way. Reset ephone, delete and recreate ephone and ephone-dn, are things that can be tried done with variable success. Often, only reload router works.

What should be done in first place, is to update IOS to resolve whatever bug that causes the problem.

MARK BAKER Tue, 03/06/2012 - 05:33


I scheduled a reboot of the router last night and it was cleared this morning. Your right, an upgrade is the only solution to this issue.

wdejulio312 Tue, 03/06/2012 - 08:17

I fixed it with a "Ctrl-alt-del" unfortunately.

Cisco SMB service center didn't have a way.  I did change the config to remove the need for an octo-line. I basically just used multiple ephone-dns sharing the same numbers and then put them in an overlay.

In what version is this issue resolved? Is there a bug id?



This Discussion