Allowing extension to be seen for external call

Unanswered Question
Jan 24th, 2008

I have a question for the forum is there away to make an external call to someone and they will be able to see your hold number instead of the PBX number. (Ex. 777-777-7777 is my extension what others are seeing is 777-777-7000 Company number) Is this a ISP issue or can I change it in the Call Manager 4.1

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
damrut5763 Thu, 01/24/2008 - 10:28

Yes we're using ISDN PRI's coming into the router with H323 gateway.

damrut5763 Thu, 01/24/2008 - 10:36

Actually we're using ISDN PRI's coming into 2 routers one using H323 gateway and the other MGCP.

Paolo Bevilacqua Thu, 01/24/2008 - 11:21

Ok, since at least the MGCP GW requires config in CM, you need to tweak "external phone number mask" in there so that the extension is presented with the number of digits that telco expects.

Unfortunately I'm unable to give you the details but someone else will.

Then you verify on the GW with "debug ISDN q931" and "term mon" when making a call.

damrut5763 Thu, 01/24/2008 - 11:36

I tried it with my extension and it didn't work I am still showing the Company receptionist number i.e 777-777-7000 instead of my extension.

Rob Huffman Fri, 01/25/2008 - 05:39

Hi Damon,

I'm sure Paolo is onto something here (he always is!) You should also take a moment to contact your Telco/Provider to see if all calls are being marked with the Corporate number. In many cases the Telco does charge extra $ for individual Name and Number display and their default may be what you are seeing.

Just in case,

Rob

damrut5763 Fri, 01/25/2008 - 06:47

Thanks I will contact my ISP I thought I could override the default setting!!!!

Paolo Bevilacqua Fri, 01/25/2008 - 06:58

But if you don't check your debug isdn q931 first, you cannot be sure that you are sending out the calling number in the proper format, including type/plan.

Paolo Bevilacqua Fri, 01/25/2008 - 10:52

Hi,

you are sending out the full main number:

Calling Party Number i = 0x0181, '6782524000'

supposedly you should send the 4 digits extension only.

Please review you CM configuration so that four digits are sent out. Sorry, I can't help you, but others (and the manual) surely can.

Actions

This Discussion