UCCE 7.2 - Dialed Number Plan Bulk (Insert)

Unanswered Question

This tool would not start for me. It gives the message:

"Routing client of the CallManager/SoftACD PG, System PG or Agent Routing Service PG type must be configured prior to dial number plan".

I have a PC Generic (PIM for CallManager, PIM for CVP) rather than a CallManager/SoftACD PG + PIM for CallManager and a VRU PG + PIM for CVP.

So I created a DUMMY CallManager/SoftACD with a routing client and tried again. Same message.

I stopped and restarted the Distributor and now it allows me to run the tool, but the routing client for the CallManager PIM cannot be selected - only the dummy RC I just created, and (stranegely enough) the CVP RC. Making it useless.

I don't recall this problem before with previous installations.

Has this recently been strengthened for System PG and/or Agent Routing Service PG?



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)

I'm back in the lab today and checked my 7.1(4) system. This has a PG Generic PG with PIMs for CallManager, IPIVR, CVP 3.x, CVP Warm Transfer 3.x and there is no problem with the Dialed Number Plan Bulk (Insert) configuration tool.

Looks like this was added to 7.2. I'll have to install the service release 7.2(3) and see if this has been fixed, but I see no mention of the bug in the release notes for 7.2(2) and 7.2(3). Bummer.



Spoke to soon about this.

I finally tried to use this tool and it will not allow me to select the CallManager PIM Routing Client. The CVP PIM.RC shows up in the selection box - but not the CUCM PIM.RC.

The PG has been installed as a Generic PG and ICM is applying some checks at this level. Naturally, I don't see any dialed numbers that exist on the CallManager PG.

I even tried to create the DNP entry by an import from a file, providing the ID of the CallManager PIM Routing Client (5000) and the ID (5040) of the Dialed Number I created on the CUCM PIM.

The import seems to show the dialed number OK (it translates the ID to CM_PIM.RC.65572) but blanks out the routing client and I can't defeat it.

I have heard from others that there is no problem if you have a PG for CallManager and a PG for CVP. I sure don't want to have to do that.

It looks like Cisco are applying checks to prevent erroneous use of the DNP but these checks are preventing correct use of the tool.

Has anyone had this problem and solved it?



Mmm, I'm an idiot. I had incorrectly set the type on the CUCM PIM routing client to "PG Generic" and it needs to be "IPCC / Enterprise Agent". Changed this (thanks to Nik Thomas at Cisco TAC) and restarted the Distributor. I can import and create directly in the DNP Bulk tool.

We now return to our usual program.




This Discussion