Backup ISDN line comes up When Primary Frame has not failed.

Unanswered Question
Jan 24th, 2008

I have a cisco 2800 router with Frame-Relay Primary and ISDN a backup. The problem we're haveing is the ISDN backup circuit is coming up even though the Primary Circuit has not failed. Can you please take a quick look at the config below and let me know what you think

interface Loopback0

ip address 172.17.65.137 255.255.255.252

!

interface FastEthernet0/0

ip address 172.17.88.1 255.255.255.128

no ip redirects

no ip proxy-arp

no ip mroute-cache

duplex full

speed 100

no mop enabled

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

no ip redirects

no ip proxy-arp

encapsulation frame-relay IETF

no ip mroute-cache

load-interval 30

no fair-queue

service-module t1 timeslots 1-6

cdp enable

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial0/0/0.1 point-to-point

bandwidth 384

ip address 172.17.123.130 255.255.255.128

no ip redirects

no ip proxy-arp

no ip mroute-cache

frame-relay interface-dlci 223

class 360

!

interface BRI0/1/0

ip address 172.17.212.123 255.255.255.128

no ip redirects

no ip proxy-arp

encapsulation ppp

dialer idle-timeout 60

dialer map ip 172.17.212.1 name 211-ISDN/FAIR broadcast 1028819094847471

dialer map ip 172.17.212.1 name 211-ISDN/FAIR broadcast 19xx4xx7471

dialer load-threshold 2 either

dialer-group 1

isdn switch-type basic-ni

isdn point-to-point-setup

isdn spid1 x166439684x1x1

isdn spid2 x166439687x1x1

no cdp enable

ppp authentication chap

ppp multilink

!

router eigrp 1

network 172.17.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip route 0.0.0.0 0.0.0.0 172.17.212.1 200

ip route 172.17.212.1 255.255.255.255 BRI0/1/0

!

!

ip http server

ip http authentication local

ip http secure-server

ip tacacs source-interface FastEthernet0/0

!

ip access-list extended Sacramento_ACL

permit ip host 172.17.65.137 host 172.17.65.125

permit ip 172.17.88.0 0.0.0.255 any

!

!

But when the primary Frame-relay link is still active, the ISDN link comes up. See log messeges from the router below:

Jan 23 12:58:51.639: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/1/0:1, changed

state to up

Jan 23 12:58:59.420: %LINK-3-UPDOWN: Interface BRI0/1/0:2, changed state to up

Jan 23 12:58:59.420: %ISDN-6-CONNECT: Interface BRI0/1/0:2 is now connected to 19094847471

N/A

Jan 23 12:59:00.759: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/1/0:2, changed

state to up

Jan 23 13:00:14.173: %ISDN-6-DISCONNECT: Interface BRI0/1/0:1 disconnected from 19094847471

211-ISDN/FAIR, call lasted 83 seconds

Jan 23 13:00:14.413: %LINK-3-UPDOWN: Interface BRI0/1/0:1, changed state to down

Jan 23 13:00:15.117: %ISDN-6-DISCONNECT: Interface BRI0/1/0:2 disconnected from 19094847471

211-ISDN/FAIR, call lasted 75 seconds

Jan 23 13:00:15.361: %LINK-3-UPDOWN: Interface BRI0/1/0:2, changed state to down

Jan 23 13:00:15.413: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/1/0:1, changed state to down

Jan 23 13:00:16.361: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/1/0:2, changed state to down

Jan 23 14:28:14.177: %LINK-3-UPDOWN: Interface BRI0/1/0:1, changed state to up

Jan 23 14:28:14.177: %ISDN-6-CONNECT: Interface BRI0/1/0:1 is now connected to 19094847471

N/A

Jan 23 14:28:15.516: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/1/0:1, changed

state to up

Jan 23 14:28:23.446: %LINK-3-UPDOWN: Interface BRI0/1/0:2, changed state to up

Jan 23 14:28:23.446: %ISDN-6-CONNECT: Interface BRI0/1/0:2 is now connected to 19094847471

N/A

Jan 23 14:28:24.782: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/1/0:2, changed

state to up

Jan 23 14:29:36.847: %ISDN-6-DISCONNECT: Interface BRI0/1/0:2 disconnected from 19094847471

123-2811-1#

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Thu, 01/24/2008 - 18:00

Larry

There are some things that would be helpful that you have deleted in the config that you posted. In particular the BRI has dialer-group 1 but you have not given us dialer-list 1. So we do not know what is interesting traffic that could bring up the ISDN interface.

Given the time interval indicated in the logs that you posted I discount the possibility that EIGRP traffic over the ISDN or CDP traffic over the ISDN may be the cause. But it would be good to know what is "interesting" on this side.

My other thought is that the log messages that you have posted do not clarify whether this router is initiating the calls or is activating when it receives calls. If you run debug dialer through several cycles of activation and post the output it should help clarify this aspect. It might also be helpful if you would run debug ppp negotiation and post that output.

HTH

Rick

lacox3131 Mon, 01/28/2008 - 07:42

Rick,

Here is the dialer-list 1;

access-list 177 deny eigrp any any

access-list 177 deny ip any 224.0.0.0 0.255.255.255

access-list 177 deny ip any host 255.255.255.255

access-list 177 permit ip any any

dialer-list 1 protocol ip list 177

Richard Burts Mon, 01/28/2008 - 08:55

Larry

Thank you for posting the dialer list information that I asked about. It does clarify that EIGRP (as well as 224.x.x.x multicast) is not interesting. Perhaps run debug dialer and post the output when it has run through a couple of cycles of the ISDN interface going active.

HTH

Rick

Actions

This Discussion