Trasfer for Analog Phones (FXS)

Unanswered Question
Jan 25th, 2008

Hello, collegues.

I have a problem with configuring function transfer on CCME for the analog device. Can you say, please, in what ways it can be realized? And also, do you known were is the examples of config with realization of this function?

On cisco.com I have found clause "SCCP Controlled Analog (FXS) Ports with Supplementary Features in Cisco IOS Gateways". However, using given clause to create transfer, I could not achieve positive result.

Therefore, I address to you.

TIA

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Fri, 01/25/2008 - 02:52

Why that didn't not work for you? Does the STCAPP work, can you use the FXS ports in SCCP modem to make and palce calls ?

grisadovoy Fri, 01/25/2008 - 03:02

Hi,

Thank you, for youre answer.

I was configure STCAPP on my CCME. When I want to do transfer - I press hook-flash and CCME give me tone. So I dial number of transfer-to. But after dial number call don`t transered - it remain on the same FXS.

Thanks

grisadovoy Fri, 01/25/2008 - 04:36

I have following scheme:

AP---CCME---AP(333)

(100) |

|

|

AP(444)

where is AP - it is analog phone.

So I call from 333 to 100. Call is terminating. On the phone 100 I press #2 - CCME give me tone. I dial 444, but transfer don`t work. In addition I hear on phone 333 dialed number from 100.

There is my config. Can you check, please, my config

stcapp ccm-group 1

stcapp

!

stcapp feature access-code

!

!

voice-card 0

no dspfarm

!

archive

log config

hidekeys

!

!

interface GigabitEthernet0/0

ip address 192.168.1.1 255.255.255.0

duplex full

speed 100

!

interface GigabitEthernet0/1

ip address 172.23.4.4 255.255.255.0

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 172.23.4.1

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/0/2

timeouts ringing infinity

station-id number 100

!

voice-port 0/0/3

!

voice-port 0/1/0

!

voice-port 0/1/1

!

!

!

sccp local GigabitEthernet0/1

sccp ccm 172.23.4.4 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

!

!

dial-peer voice 100 pots

service stcapp

port 0/0/2

!

dial-peer voice 333 pots

destination-pattern 333

port 0/0/0

!

dial-peer voice 444 pots

destination-pattern 444

port 0/0/1

!

!

!

telephony-service

max-ephones 58

max-dn 192

ip source-address 192.168.1.1 port 2000

max-conferences 8 gain -6

transfer-system full-consult

transfer-pattern ...

create cnf-files version-stamp 7960 Jan 24 2008 13:52:33

!

!

ephone-dn 1 dual-line

number 100

!

!

ephone 1

mac-address 3C39.99D2.9002

button 1:1

!

end

CCME#

Thanks

grisadovoy Fri, 01/25/2008 - 05:27

I disabled station-id number on voice-port. But, it is not correct problem.

I am frightened with following record:

TAG Type AD OUT

port MIN STAT

100 pots up down

It is correct, what the status down at dial-peer on which it is applied stcapp?

Thanks

Paolo Bevilacqua Fri, 01/25/2008 - 06:47

Hi, since the stcapp config is a bit complicated, is difficult to diagnose what is wrong from remote, it is one of these cases where one needs to be on site to troubleshoot.

As time permits I will try a config like your to see if I can have it working.

grisadovoy Fri, 01/25/2008 - 07:16

Thanks a lot for active participation in the decision of my problem. If you will have news, inform me, please. I try to solve this problem about 2 weeks.

Thanks

Actions

This Discussion