isdn layer 3?

Unanswered Question
Jan 25th, 2008
User Badges:

Im having problem establishing a remote isdn bri site to establish the call to HQ.

I can see that when i do the " clear int bri 1/0" the layer 1 active and layer 2 mutiple frames established.

however when i try to do a test call " isdn test int bri 1/0 xxx" the call fails with error " service/option unspecified.



Here is the debug q931 output:

Jan 25 23:19:09.913 UTC: ISDN BR0/1/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num 0xxx

Jan 25 23:19:09.913 UTC: ISDN BR0/1/0 Q931: TX -> SETUP pd = 8 callref = 0x7A

Bearer Capability i = 0x8890

Standard = CCITT

Transfer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x81

Called Party Number i = 0x80, 'xxxx'

Plan:Unknown, Type:Unknown

Jan 25 23:19:10.205 UTC: ISDN BR0/1/0 Q931: RX <- SETUP_ACK pd = 8 callref = 0xFA

Channel ID i = 0x89

Jan 25 23:19:10.205 UTC: ISDN BR1/1 Q931: RX <- SETUP_ACK pd = 8 callref = 0xFA

Channel ID i = 0x89

Jan 25 23:19:10.641 UTC: ISDN BR0/1/0 Q931: RX <- CALL_PROC pd = 8 callref = 0xFA

Jan 25 23:19:10.641 UTC: ISDN BR1/1 Q931: RX <- CALL_PROC pd = 8 callref = 0xFA

Jan 25 23:19:10.737 UTC: ISDN BR0/1/0 Q931: RX <- DISCONNECT pd = 8 callref = 0xFA

Cause i = 0x82BF - Service/option not available, unspecified

Jan 25 23:19:10.737 UTC: ISDN BR1/1 Q931: RX <- DISCONNECT pd = 8 callref = 0xFA

Cause i = 0x82BF - Service/option not available, unspecified

Jan 25 23:19:10.741 UTC: ISDN BR0/1/0 Q931: TX -> RELEASE pd = 8 callref = 0x7A

Cause i = 0x80BF - Service/option not available, unspecified

Jan 25 23:19:10.937 UTC: ISDN BR0/1/0 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xFA

Jan 25 23:19:10.937 UTC: ISDN BR1/1 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xFA

Jan 25 23:19:12.929 UTC: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/1/0, TEI 111 changed to down

Jan 25 23:19:12.937 UTC: ISDN BR0/1/0 Q931: Ux_DLRelInd: DL_REL_IND received from L2



Appreciate any advice!


tks

Jay

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Bernd.Waterkamp Sat, 01/26/2008 - 08:47
User Badges:

Useful Debugging Information (additional information is linked in these two documents):

"Troubleshooting ISDN BRI Layer 3 Using the debug isdn q931 Command" http://www.cisco.com/en/US/tech/tk801/tk379/technologies_tech_note09186a0080093c1a.shtml


"Understanding debug isdn q931 Disconnect Cause Codes" http://www.cisco.com/warp/public/129/isdn_disc_code.html has an entry for Code 83BF:


"The network or remote equipment cannot provide the service option that the user requests, due to an unspecified reason. A subscription problem can cause this issue."


You got disconnected by your telco because the remote site is not able to connect to an isdn data call. Please check if you are calling the correct number/router if this is an ISDN-port.

jay77jay77 Sun, 01/27/2008 - 00:21
User Badges:

Thanks.The HQ site is workin fine with other remote sites.

Bernd.Waterkamp Sun, 01/27/2008 - 03:11
User Badges:

Hmm, just noticed two things in your log:


- Why are two interfaces (BR0/1/0 and BR1/1) dialing at the same time?


- The error message belongs to the *local* isdn-connection, not to your remote/hq-site: "Cause i = 0x82BF" -> The "Understanding debug..." document has a list of Cause Code Origination Points: 82-the public network near the local user (local telco switch)


-> The local telco system stops the outgoing isdn data call. If the isdn-switch-type is correct and your sh isdn status is fine, you should check if this router is really connected to the correct isdn-BRI. If this is a new connection ask your telco to check if it has the correct settings for use as a isdn-bri-dialup/data-connection.


What happens if you try to dial in from your hq site?

jay77jay77 Mon, 01/28/2008 - 17:47
User Badges:

i will be escalating to the telco again.

Meanwhile anyother thoughts will be appreciated.

paolo bevilacqua Tue, 05/19/2009 - 08:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Two years old thread and you expect a reply ?

CSCO11167812 Tue, 05/19/2009 - 08:55
User Badges:

Hi Jay,


a possible reason could be that the bearer capability 'Unrestricted Digital' is not allowed or programmed on the ISDN line.


Did you look at the HQ site to see if the call was alerting on the router at that site.


Regards


Michel

Actions

This Discussion