ASA 5505 cannot ping Internet hosts by name ?

Unanswered Question
Jan 26th, 2008

I can ping by IP address but not by name. I also cannot surf the web since name resolution does not work. My client's default gateway and DNS setting points to 10.1.1.1, which is the inside interface of the ASA.

My Config here >

ASA Version 8.0(3)

!

hostname ciscoasa

domain-name default.domain.invalid

enable password xxxxxxxxxxx encrypted

names

!

interface Vlan1

nameif inside

security-level 100

ip address 10.1.1.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

pppoe client vpdn group bellsouth

ip address pppoe setroute

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

passwd xxxxxxxxxxx encrypted

boot system disk0:/asa803-k8.bin

ftp mode passive

dns server-group DefaultDNS

domain-name default.domain.invalid

same-security-traffic permit intra-interface

pager lines 24

logging asdm informational

mtu inside 1500

mtu outside 1500

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-603.bin

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0

route outside 0.0.0.0 0.0.0.0 65.14.x.x

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout uauth 0:05:00 absolute

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 10.1.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

telnet timeout 5

ssh timeout 5

console timeout 0

vpdn group bellsouth request dialout pppoe

vpdn group bellsouth localname [email protected]

vpdn group bellsouth ppp authentication pap

vpdn username [email protected] password ********* store-local

dhcpd auto_config outside

!

dhcpd address 10.1.1.2-10.1.1.33 inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

message-length maximum 512

policy-map global_policy

class inspection_default

inspect ftp

inspect h323 h225

inspect h323 ras

inspect rsh

inspect rtsp

inspect esmtp

inspect sqlnet

inspect skinny

inspect sunrpc

inspect xdmcp

inspect sip

inspect netbios

inspect tftp

inspect icmp

inspect dns preset_dns_map

!

service-policy global_policy global

prompt hostname context

Cryptochecksum:xxx

: end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
srue Sun, 01/27/2008 - 04:56

The asa5500 series cannot act as DNS servers. You need to point your clients to a different DNS server - like 4.2.2.4 or something.

dkraut Sun, 01/27/2008 - 10:51

Guys, sorry I didn't explain it better, I'm not trying to make the ASA act as DNS, just trying to get it to pass through the DNS info from my ISP. What baffles me is that I had the entry checked in ASDM to enable DHCP auto configuration from interface outside, but that didn't seem to work? For some reason the ASA refuses to pass my BellSouth DNS server info to internal DHCP clients. My D-Link did this without an issue. Anyway, adding dhcpd dns x.x.x.x worked! I can't tell you how many hours I've spent troubleshooting this. Cheers!

Actions

This Discussion