2501 router connecting to cable internet?

Unanswered Question
Jan 26th, 2008

My topology looks like this:

Cox cable internet cloud -> Motorola Cable modem -> [e0] 2501 router [s0] -> [s0] 2501 router [e0] -> 2924 switch -> host

My mission is get connect to the internet. But its been all fails so far. The e0 port on the 2501 router does not offer "ip address negotiated" command. I figured that would be all I needed to do since I get an ip address assigned dynamically by the cable company.

I could hook up a linksys router to get the ip dynamically, then copy that information over somehow onto the 2501 router to get connected. Would that help at all? By looking at the linksys router I can determine what the public ip address is, the DNS, gateway and subnet. It is NOT PPPoE.

Thanks for any help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
yumologycccp Sat, 01/26/2008 - 22:32

I'm running the 12.1(21) IOS. I have 16MB DRAM and 8MB Flash. I tried to upgrade the IOS but #1 Cisco won't let me download it, and #2 It's really hard finding one with that low of Flash mem.

This is a really good start though. Unfortunately my IOS doesn't have the command "ip address dhcp" but it certainly leads me in a better direction.

I have to figure out how to download IOS's from cisco. That part if pretty frustrating.

yumologycccp Tue, 01/29/2008 - 23:58

Ok I'm confused again.

I am now running 12.1(2)T, so I do have the 'ip addr dhcp' command. And when I assign it to my E0 port, I get a private ip address. Something like I can't ping my dns server with that ip address. I've tried to release and get a new one, but each time I get that same private ip. I should be getting something like but it doesn't do that.

Any help is greatly appreciated. So far I'm highly satisfied with the direction so far, just missing a few key elements.

Edison Ortiz Wed, 01/30/2008 - 15:17

Interesting, that IP must be assigned by a DHCP server on that broadcast domain. It seems your ISP is assigning that IP to you. If you plug-in a workstation instead of the 2501, do you get a different IP ?

yumologycccp Wed, 01/30/2008 - 17:58

I have a linksys router that I currently use to get online. When I plug it in, at first I get a private ip (in the class C range 192.168.100.x) then after a minute I get a global ip address assigned to me, sometimes i have to recycle the modem.

I just tried changing the mac address on the E0 interface of my cisco router to my linksys router to see if that helps but i still get the ip assigned to me. Will I have to do any further configuration after getting an ip? Like do i have to make a dhcp pool and import things, wouldn't that automatically set up my default-gateway and dns servers, or do i have to do that manually, and how would i find out what my default-gateway is? Oh, I'd have to set up NAT manually thats for sure, and not a problem for me.

yumologycccp Wed, 01/30/2008 - 23:00

In case you're wondering here's the output from "debug dhcp detail". And YES I have the same topology as the original post, this router is directly connected to the modem using ethernet. I will call Cox today to see if they know.

router_2501(config)#int e0


01:52:32: %LINK-5-CHANGED: Interface Ethernet0, changed state to administrativel

y down

router_2501(config-if)#no shut

01:52:35: DHCP: SRelease attempt # 1 for entry:

01:52:35: Temp IP addr: for peer on Interface: Ethernet0

01:52:35: Temp sub net mask:

01:52:35: DHCP Lease server:, state: 7 Releasing

01:52:35: DHCP transaction id: 1B02

01:52:35: Lease: 86400 secs, Renewal: 43200 secs, Rebind: 75600 secs

01:52:35: Next timer fires after: 00:00:00

01:52:35: Retry count: 1 Client-ID: cisco-0000.0c3f.249d-Et0

01:52:35: DHCP: SRelease placed Server ID option:

01:52:35: DHCP: SRelease: 277 bytes

01:52:36: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up

01:52:36: DHCP: SRelease attempt # 2 for entry:

01:52:36: Temp IP addr: for peer on Interface: Ethernet0

01:52:36: Temp sub net mask:

01:52:36: DHCP Lease server:, state: 7 Releasing

01:52:36: DHCP transaction id: 1B02

01:52:36: Lease: 86400 secs, Renewal: 43200 secs, Rebind: 75600 secs

01:52:36: Next timer fires after: 00:00:00

01:52:36: Retry count: 2 Client-ID: cisco-0000.0c3f.249d-Et0

01:52:36: DHCP: SRelease placed Server ID option:

01:52:36: DHCP: SRelease: 277 bytes

01:52:37: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed sta

te to up

01:52:37: DHCP: SRelease attempt # 3 for entry:

01:52:37: Temp IP addr: for peer on Interface: Ethernet0

01:52:37: Temp sub net mask:

01:52:37: DHCP Lease server:, state: 7 Releasing

01:52:37: DHCP transaction id: 1B02

01:52:37: Lease: 86400 secs, Renewal: 43200 secs, Rebind: 75600 secs

01:52:37: Next timer fires after: 00:00:00

01:52:37: Retry count: 3 Client-ID: cisco-0000.0c3f.249d-Et0

01:52:37: DHCP: SRelease placed Server ID option:

01:52:37: DHCP: SRelease: 277 bytes

01:53:08: DHCP: QScan: Purging entry

01:53:08: DHCP: deleting entry 240414 from list

01:53:08: Temp IP addr: for peer on Interface: Ethernet0

01:53:08: Temp sub net mask:

01:53:08: DHCP Lease server:, state: 8 Purging

01:53:08: DHCP transaction id: 1B02

01:53:08: Lease: 86400 secs, Renewal: 43200 secs, Rebind: 75600 secs

01:53:08: No timer running

01:53:08: Retry count: 0 Client-ID: cisco-0000.0c3f.249d-Et0


yumologycccp Wed, 01/30/2008 - 23:40

err. that last post is what it looks like when i release only. here's what it looks like when i am acquiring an address, and note: pings to all the private addresses and dns servers do not work. and also note, the dns was changed to conceal actual ip's but its giving me the RIGHT dns entries, but everything else is wrong.


02:15:54: DHCP: SRequest attempt # 2 for entry:

02:15:54: Temp IP addr: for peer on Interface: Ethernet0

02:15:54: Temp sub net mask:

02:15:54: DHCP Lease server:, state: 1 Selecting

02:15:54: DHCP transaction id: 8D0

02:15:54: Lease: 86400 secs, Renewal: 0 secs, Rebind: 0 secs

02:15:54: Next timer fires after: 00:00:02

02:15:54: Retry count: 2 Client-ID: cisco-0000.0c3f.249d-Et0

02:15:54: DHCP: SRequest- Server ID option:

02:15:54: DHCP: SRequest- Requested IP addr option:

02:15:54: DHCP: SRequest placed lease len option: 86400

02:15:54: DHCP: SRequest: 315 bytes

02:15:54: B'cast on Ethernet0 interface from

02:15:54: DHCP: Received a BOOTREP pkt

02:15:54: DHCP: Scan: Message type: DHCP Ack

02:15:54: DHCP: Scan: Server ID Option: = AC134910

02:15:54: DHCP: Scan: Lease Time: 86400

02:15:54: DHCP: Scan: Subnet Address Option:

02:15:54: DHCP: Scan: DNS Name Server Option:,, &68.10


02:15:54: DHCP: Scan: Domain Name: ph.cox.net

02:15:54: DHCP: Scan: Router Option:

02:15:54: DHCP: rcvd pkt source:, destination:

02:15:54: UDP sport: 43, dport: 44, length: 318

02:15:54: DHCP op: 2, htype: 1, hlen: 6, hops: 1

02:15:54: DHCP server identifier:

02:15:54: xid: 8D0, secs: 0, flags: 8000

02:15:54: client:, your:

02:15:54: srvr:, gw:

02:15:54: options block length: 70

02:15:54: DHCP Ack Message

02:15:54: DHCP: Lease Seconds: 86400

02:15:54: DHCP: Server ID Option:

02:15:55: DHCP Proxy Client Pooling: ***Allocated IP address:

02:15:55: Allocated IP address =


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to, timeout is 2 seconds:


Success rate is 0 percent (0/4)

02:18:54: %SYS-5-CONFIG_I: Configured from console by console


02:21:39: DHCP: Received a BOOTREP pkt Not for us..: xid: 0x3EB892A2

yumologycccp Thu, 01/31/2008 - 17:57

Ok I have discovered the problem is something specific with this router. I have used my friends 3600 and 7200 routers and they successfully connect to the internet just fine. I have used my cheapy soho 3com router and linksys routers and they sucessfully connect just fine. I called cox and they say its my side not theirs. I have turned other local routers into DHCP servers, and my 2501 connects to them perfectly fine. But still the 2501 refuses to connect to the internet as a dhcp client, it still gets the exact same private ip address every time.

So. What exactly needs to go on for me to use a router to connect to the internet using 'ip addr dhcp' because I believe I'm still missing something important to put on this router.

yumologycccp Thu, 01/31/2008 - 18:05

what does the "T" mean in Cisco IOS versions? like 12.1T, what is this? What am i trying to look for when looking for T's?

Edison Ortiz Thu, 01/31/2008 - 20:23

It's just a different track. I believe it means "Technology" train where new features are tested before they make it into the mainline train.



Edison Ortiz Thu, 01/31/2008 - 20:22

You got me there. I have no idea from where the router is pulling that IP address and how different it works on other SOHO routers.



yumologycccp Thu, 01/31/2008 - 20:38

Well thanks for trying anyways edison. you did teach me how to set up dhcp. which was a big help. I actually found what the problem is. A known cisco bug (ID CSCdx67972). Fixed in later versions but no fix for the one i have. It's too bad cisco refuses to support my equipment for me and give me a bug free IOS. I guess I'll have to stick with 3com due to it being the router that works...


This Discussion