Switch Uplink - Undersize Packets

Unanswered Question
Jan 27th, 2008

I have a 3750 switchport connected to a 3845 router. I am seeing a high number of "UnderSize" packets when I issue a "show interface counters errors" command. I have hardset the interfaces to Full/1000, but this has not helped. Any help would greatly be appeciated.

Will Rate Posts.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Sun, 01/27/2008 - 15:50

Are you seeing that only on the switch side?

What version of IOS running on the switch and router?

__

Edison.

mparella Sun, 01/27/2008 - 15:56

Switch: 12.2(25)SEB4

Router: 12.4(15)T1

Yes, just on the switch port. That command isn't valid on the router.

Edison Ortiz Sun, 01/27/2008 - 16:14

On the router side, check for runts on input and output packets. Runts are equivalent to undersize packets.

Can you post the portion of the config from the router and the switch?

Also, post the show interface from both devices.

HTH,

__

Edison.

mparella Mon, 01/28/2008 - 06:15

Doesn't look like any runts showing up. I am going to make a really basic change that I should have done in the first place which is change the patch cable.

Otherwise it's a pretty simple configuration.

I attached a txt file with interface configs, etc.

Thanks for all of your help Edison.

Attachment: 
r.crist Mon, 01/28/2008 - 08:41

I saw the same during a tech refresh. We replaced 2600 routers with 3700/3800 routers and I immediately noticed the undersized frame counters incrementing on the switch interfaces, but not on the router interfaces. We captured data and saw there were really no undersized frames being transmitted. I opened a TAC case and this is what I was told: "Your issue is purely cosmetic issue and does not have any performance issues and also does not explicitly requires IOS upgrade.. Please co-ordinate with the NCE for IOS upgrade."

TAC engineer also forwarded this URL:

http://www.cisco.com/en/US/customer/products/hw/switches/ps5206/products_field_notice09186a00802cac62.shtml

TAC case number was 605693447, and was opened in April of 2007. We are still seeing the undersized frame errors incrementing. -Rich

mparella Mon, 01/28/2008 - 08:49

Always makes me nervous to ignore stuff liek this. Thanks for your help, I appreciate your insight.

r.crist Mon, 01/28/2008 - 08:54

I with you. I really dislike the "ignore it, it's only a cosmetic bug" answer. Pay no attention to the man behind the curtain.. I argued with the TAC engineer for a while via email, but he finally just said to upgrade IOS on the 3750's. Which we did (and no easy feat at that - 1900 3750's on our network). We're running 12.2(25)SEE2 now and still seeing the errors increment. We don't plan to upgrade the 3750's again until Cisco works out some of the stacking issues. I'm curious to see if someone from Cisco will have any input on this. Will keep an eye on this conversation. Thanks, and good luck.

Edison Ortiz Mon, 01/28/2008 - 08:56

Rich may be onto something as this could be a cosmetic issue. However, your configuration is rather odd.

You have the router and switch configured for trunking. The router is tagging for packets on Vlan 26 and sending packets untagged for Vlan 1.

The switch is sending untagged packets for Vlan 25 (that's a native Vlan mismatch) and any other Vlan as tagged. The access vlan and voice vlan on the switchport configuration isn't doing anything.

I'm not sure if this is causing the problem here but it must be corrected for an ideal design.

HTH,

__

Edison.

Richard Bradfield Wed, 08/06/2008 - 18:47

was this ever resolved, i am running 12.2(35) se5 on the 3750s and 12.4(T9) on 3845 and still seeing the errors

Actions

This Discussion