Switch not delivering power to 7940G-GE

Unanswered Question
Jan 28th, 2008

I have a 24-port Catalyst 3560G that is providing power to a dozen or so IP phones. I recently unplugged one of the phones and when I went to go plug it back in the power wouldn't resume. I tried replacing the phone, no power. I tried plugging both phones directly into the switch (bypassing cabling plant), still no power. I've tried different ports, doing a shut/no shut, forcing power on the phone (power inline static iface cmd). Basically, everything short of rebooting the switch which I'm reluctant to do because I fear that I might lose power to the rest of the phones connected to it. Any advice or troubleshooting tips would be greatly appreciated since the PoE troubleshooting section of the Catalyst IOS manual is woefully short.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Brandon Buffin Mon, 01/28/2008 - 13:23

If you do "show power inline", does it show that you have available power? It should be the first line of the output. With the phone plugged in, does it indicate that it's providing power to the port?


zangelo_vbar Mon, 01/28/2008 - 14:14

Should have power available:

hou-sw-06#sh power inline

Available:370.0(w) Used:145.9(w) Remaining:224.1(w)

Gi0/9 auto off 0.0 n/a n/a 15.4

There is nothing that indicates that power is being provided to the port in question (Gi0/9).


Brandon Buffin Tue, 01/29/2008 - 08:30

So, if you unplug one of the other phones and plug it back in, does it power up? You may have to reload the switch.


zangelo_vbar Tue, 01/29/2008 - 11:21

I unplugged one of the other phones, plugged it back in and it came back up. Pretty puzzling.

Like I said I'm reluctant to do a reload because I might screw the rest of them up, but I may not have a choice.

Do you know of any other diagnostics I can perform before reloading?

Brandon Buffin Tue, 01/29/2008 - 11:26

Can you plug the working phone into the port of the phone that stopped working? Have you tried "shut/no shut" on the switchport?


zangelo_vbar Tue, 01/29/2008 - 11:54

Tried plugging the working phone into the other port and it didn't work.

I have tried a shut/no shut, didn't work.



robert.horrigan Thu, 01/31/2008 - 10:56

show power inline. Look at your 7941s and 60s and see how many wats they are sucking up. If it is something like 1400202 then you have a bugged IOS.

zangelo_vbar Thu, 01/31/2008 - 11:16

Yeah, I caught your earlier reply to the guy with the 4500. I checked it, and I'm either drawing 12.9 or 14.9.

I think I'm going to give an IOS upgrade a shot this weekend anyway. I can't find any bugs in the database regarding PoE.


This Discussion