Etherchannel issue on 6500 (err-disable)

Unanswered Question
Jan 28th, 2008


Currently I'm working on 2 6500 (let say, C6506 & C6509) and try to configure etherchannel between those two.

C6506 is using WS-X6724-SFP, connecting to C6509 via WS-X6816-GBIC.

If there is only 1 cable on the bundle, the port-channel is up and working properly. But when the second or third cable is join the bundle, the C6506 will generate error message:

PM-4-ERR_DISABLE: Channel-misconfig error detected on [chars], putting [chars] in err-disable state.

And the interface will went into "down" state.

I have checked both switches for misconfig, but can't found any.

The configuration is as follow:

interface <interface-id>


Switchport trunk encapsulation dot1q

Switchport mode trunk

channel-group 1 mode on

interface port-channel 1


Switchport trunk encapsulation dot1q

Switchport mode trunk

C6509 running native IOS 12.1(13)E6.

C6506 running native IOS 12.2(18)SXE6.

I tried different combination on both switches, ON/ON, ACTIVE/PASSIVE, DESIRABLE/AUTO. Nothing worked.

The last thing is instead of connecting to C6509/WS-X6816-GBIC, I'm using GBIC on Supervisor (same switch, WS-X6K-S2U-MSFC2) and it worked. But the thing is using Supervisor GBIC I can only achieve max 2GB on the bundle.

Please help me solving this, and Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
adirinaldi Tue, 01/29/2008 - 18:39

Hi Arun,

I have check all the necessary conditions for etherchannel, and everything are met.

But one thing, I haven't try is to hardcode duplex setting on both interfaces, currently they are running default duplex setting. I'm afraid that the default duplex setting between 6816-GBIC & SFP is different.


yjdabear Tue, 01/29/2008 - 07:44

Check using "show monitor" to make sure none of the ports in the Etherchannel is not a member of any SPAN session.

adirinaldi Tue, 01/29/2008 - 18:40

Hi Yi,

I have issue the show monitor before and none of the ports are member of SPAN.


glen.grant Tue, 01/29/2008 - 16:24

Take them down and then bring them all up at the same time with the interface range command and see what happens or do a shut on the int portchannel 1 interface and then do a no shut .

adirinaldi Tue, 01/29/2008 - 18:43

Hi Glen,

Yes, i have tried to shut/no shut the interface at the same time none of them worked, I suspect that the default duplex setting between line cards is different, I'm going to try hardcode the duplex setting.


Konstantin Dunaev Wed, 01/30/2008 - 01:24

could you post here the configuration of all 4 ports and the exactly syslog messages which you see?

the most usual problem is the different VLAN list or differnt native VLAN.

if you suspect the speed/dupley mistmatch then try to configure them manually.


This Discussion