WCCP router identifier question

Unanswered Question
Jan 28th, 2008
User Badges:

Hi, all,

I have a subnet consist of a 2610XM router, a catalyst 2950(24 port). Since my router has only one FE port, it's configured as below:


!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

interface FastEthernet0/0

description CONNECTION TO CISCO_SW_PORT_24

no ip address

no ip proxy-arp

speed 100

full-duplex

no cdp enable

no mop enabled

!

interface FastEthernet0/0.2

description VLAN2_connect_to_outside

encapsulation dot1Q 2

ip address assigned_ip_addr 255.255.255.0

ip nat outside

ip virtual-reassembly

!

interface FastEthernet0/0.3

description VLAN3_192.168.1.0_inside_net

encapsulation dot1Q 3

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/0.4

description VLAN4 _192.168.3.0_inside_net

encapsulation dot1Q 4

ip address 192.168.3.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/0.5

description VLAN5_192.168.4.0_inside_net

encapsulation dot1Q 5

ip address 192.168.4.1 255.255.255.0

ip nat inside

ip virtual-reassembly


ip route 0.0.0.0 0.0.0.0 assigned_ip_addr_gateway

!

ip nat pool blackout assigned_ip_addr assigned_ip_addr netmask 255.255.255.0

ip nat inside source list 101 pool blackout overload

ip nat inside source static 192.168.1.100 assigned_ip_addr

access-list 101 permit ......

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


The internal ip address 192.168.1.100 is assigned to a Fedora machine acting as a webserver, accessing vlan3. And the router FE port is connecting to one of the SW port as

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

interface FastEthernet0/24

description TRUNK_CONNECTION_2610ROUTER_FE0/0

switchport mode trunk

no ip address

duplex full

speed 100

!

ip default-gateway 192.168.1.1

ip http server

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


The whole system works fine for above configuration. Now I want to add WCCP to the router as:


!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ip wccp web-cache

!

interface FastEthernet0/0.3

description VLAN3_192.168.1.0_inside_net

encapsulation dot1Q 3

ip address 192.168.1.1 255.255.255.0

ip wccp web-cache redirect in

ip nat inside

ip virtual-reassembly

!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


Then, when I try a "show ip wccp" command on the router, the output looks like:

========================================

router#show ip wccp

Global WCCP information:

Router information:

Router Identifier: 192.168.4.1

Protocol Version: 2.0

Service Identifier: web-cache

Number of Service Group Clients: 1

Number of Service Group Routers: 1

Total Packets s/w Redirected: 4236

Process: 34

Fast: 0

CEF: 4202

Service mode: Open

......

========================================


It seems that the WCCP command is successfully sending packet to the server, becauce on the sever, when I try "tcpdump -n -i eth0 ip proto gre" the output looks like:

===============================================================

..........................

11:59:55.285674 IP 192.168.4.1 > 192.168.1.100: GREv0, length 68: gre-proto-0x883e

11:59:56.013556 IP 192.168.4.1 > 192.168.1.100: GREv0, length 68: gre-proto-0x883e

.........................

===============================================================


Here is my question: WHY THE ROUTER IDENTIFIER IS 192.168.4.1 WHILE NOT 192.168.1.1

The ip address 192.168.4.1 is in VLAN5 and I believe I did nothing to this VLAN both for the router configuration and the switch configuration. I just don't understand why wccp chooses FE0/0.5 as the router identifier.


Thanks in advance for any explanation.


Joe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
owillins Fri, 02/01/2008 - 12:39
User Badges:
  • Silver, 250 points or more

It (192.168.4.1) is the highest IP on the router and isn't used in terms of wccp conectivity. It's simply an identifier and has no impact on router.


Actions

This Discussion