LMS 3.0 High CPU consumption

Unanswered Question
Jan 29th, 2008

Hi all,

I have LMS 3.0 on Windows 2003. In the task manager i notice that the process GGScript.exe use more than 50% of the CPU resource.

Is it a normal behaviour or not ?

What is the GGScript process ? It comes with GGHelper, GGLogger and GGProxy.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
m.sir Tue, 01/29/2008 - 01:41

It looks you are hitting the bug CSCsj17702


GGScript is using 97% CPU on a LMS 5,000 devices server.

On a LMS 5,000 devices server, the task bar displays the following message although no CiscoWorks Assistant specific operations are performed:

GG script ia using 97% CPU



this comes from



Hope that helps rate if it does

MathieuJM_2 Tue, 01/29/2008 - 01:46

Thank you for your answer.

So we can add to that table that LMS 3.0 100 devices server and CiscoWorks Assistant 1.0.0 have the same bug.

Did you know for what that process family GG*** are used ?

Joe Clarke Tue, 01/29/2008 - 09:48

These process are part of the OpsXML side of CiscoWorks Assistant. The bug is still being worked on. However, our servers do not see this problem. You might try shutting down dmgtd, then killing off any leftover GG* processes (or any casuser process). Then restart dmgtd, and see if the problem persists.

grafchristian Tue, 07/01/2008 - 05:25


I am encountering the same problem on a way smaller System (evaluation Version with about 100 devices). It occured the last two weeks on Friday at 5 am, but I can't find the job that initiates this.

Is there any way to disable it? Do you have an Idea on how to restart the process/task automatically if it hangs over 90% CPU load?

(Note: We are currently working on a virtual Machine and other important Systems might be affected by the CPU usage of Cisco Works!)

Any updates when this bug will be fixed?

Martin Ermel Tue, 07/01/2008 - 06:09

Check in TaskManager if it is GGScript.exe. If that is the process just kill that process.

grafchristian Tue, 07/01/2008 - 06:17

It is the GGScript.exe. Killing that process manually works, but I am not always here when the problem occurs, so I need something automatically. I thought about an vbs-Script started by the Windows Scheduler, but I hoped for a better solution (i.e. a bug-fix).

Joe Clarke Tue, 07/01/2008 - 08:40

The bug is fixed in LMS 3.1 which ships today. If you have an SAS contract covering 3.0, you are entitled to a free DVD upgrade to 3.1. Either enter your SAS contract number in http://www.cisco.com/upgrade/ or contact your sales team.


This Discussion