Clock issues on CUE module on UC520

Answered Question
Jan 29th, 2008
User Badges:

Hi, I have a UC520 in a lab environment. My issue is to do with the automated attendant not telling me that the company is closed as I have set the opening times. Upon inspection I have found that the time on the cue is incorrect, the time on CME is correct. From my investigations the CUE module is an NTP client?. I thought it should sync with the CUE module? I'm guessing this is why I am getting issues with the automated attendant?


Any help to solve this would be greatly appreciated.


Thanks,


Craig,

Correct Answer by Brandon Buffin about 9 years 5 months ago

This is certainly one way to do it. I prefer to set an NTP server in CME and let it sync with this server instead of setting the clock manually. This will require that you set the proper time zone as well. So if you're time zone is PST:


clock timezone PST -8

clock summer-time PDT recurring

ntp server 192.5.41.40

ntp server 192.5.41.41


Then, set the proper time zone in CUE and let CUE sync with the router.


Brandon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Brandon Buffin Tue, 01/29/2008 - 06:10
User Badges:
  • Purple, 4500 points or more

Craig,

Yes, CUE is an NTP client and the the CUE time can only be set using NTP. It cannot be manually configured. Browse to the CUE GUI and then to Administration -> Network Time & Time Zone Settings. This will tell you your current NTP server(s) and the current time zone.


Hope this helps. If so, please rate the post.


Brandon

craig.corbett Tue, 01/29/2008 - 06:26
User Badges:

Thanks for the reply.


I have been to those settings on a number of occasions to specify the NTP setting but still the cue module time is still incorrect.


Brandon Buffin Tue, 01/29/2008 - 06:33
User Badges:
  • Purple, 4500 points or more

Is your NTP pointing to CME or an external NTP server? Can you ping the NTP server from the CUE module, such as:


router#service-module service-engine 0/0 session

cue>ping


Check your "service-module ip default-gateway" command under the service engine interface to be sure it has a valid default gateway.


Brandon

craig.corbett Tue, 01/29/2008 - 06:35
User Badges:

The NTP on the CUE is pointing to CME on the same UC520 router.

Brandon Buffin Tue, 01/29/2008 - 06:44
User Badges:
  • Purple, 4500 points or more

Can you ping the CME from the CUE module? Do you have "ntp master" in the CME config?


Brandon

Brandon Buffin Tue, 01/29/2008 - 07:05
User Badges:
  • Purple, 4500 points or more

Does "show clock" on the router show the correct date and time?


Brandon

craig.corbett Tue, 01/29/2008 - 07:13
User Badges:

Time is correct on cme:


cellite-UC520#show clock

15:06:02.331 PST Tue Jan 29 2008


time not correct on cue:


UC500-CUE> show clock

23:10:27.519 GMT Tue Jan 29 2008


Brandon Buffin Tue, 01/29/2008 - 07:28
User Badges:
  • Purple, 4500 points or more

One shows PST and the other GMT. Otherwise, they're approximately 4 minutes off. Is your time zone correct? Have you reloaded the CUE module since changing the time zone? If you go to Reports -> Network Time Protocol, what is the status of the NTP server?


Brandon

Brandon Buffin Tue, 01/29/2008 - 07:55
User Badges:
  • Purple, 4500 points or more

That is correct. There is an 8 hour difference between PST and GMT. Essentially, it is the same time.


Brandon

craig.corbett Tue, 01/29/2008 - 08:10
User Badges:

So CUE reads the time from CME and I have CME setup incorrect ?

craig.corbett Tue, 01/29/2008 - 08:13
User Badges:

ok so what I did in cme was:


clock timezone GMT 0


Then set the clock, and reboot CUE times are sync now.


should I have done this, this way ?

Correct Answer
Brandon Buffin Tue, 01/29/2008 - 08:26
User Badges:
  • Purple, 4500 points or more

This is certainly one way to do it. I prefer to set an NTP server in CME and let it sync with this server instead of setting the clock manually. This will require that you set the proper time zone as well. So if you're time zone is PST:


clock timezone PST -8

clock summer-time PDT recurring

ntp server 192.5.41.40

ntp server 192.5.41.41


Then, set the proper time zone in CUE and let CUE sync with the router.


Brandon

craig.corbett Tue, 01/29/2008 - 08:34
User Badges:

I understand now, I was gettin myself confused with time zones :)


thanks.

Actions

This Discussion