Recovering 2950 Ios

Unanswered Question
Jan 29th, 2008

Dear Sir,

I have typed 'erase flash' command by mistake in my catalyst 2950 switch. After reboot, it stopped at "switch:" prompt.No IOS File Is Present In the FLASH, i Am having backup of ios & i tried to Restore using hyper ternimal, xmodem option,But it is giving the message "remote system is not responding". So what should i do for reinstalling the IOS.

Please help me as early as possible.

With Regards

Sumit Patil.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
sumitpatil Thu, 01/31/2008 - 21:37

I Had Tried The Xmodem Recovery,But It Had Not Worked It Is Displaying Remote System Cannot Respond,The Images Are Attached.

Please Help Me Out Of this Problem.

sumitpatil Wed, 01/30/2008 - 09:53

I had tried the displayed procedure i.e using xmodem but it is giving the message after sometime that "remote system cannot respond".Please give me the solution.

With Regards

Sumit Patil

cpubob Wed, 01/30/2008 - 10:58

I don't have a 2950 to try but if you are in rommon and have the tftpdnld command available, try this:

rommon 1>IP_ADDRESS= Indicates the IP address for this unit

rommon 2>IP_SUBNET_MASK= Indicates the subnet mask for this unit

rommon 3>DEFAULT_GATEWAY= Indicates the default gateway for this unit

rommon 4>TFTP_SERVER= Indicates the IP address of the TFTP server

rommon 5>TFTP_FILE= c2600-js-l_121-3.bin Indicates the filename to fetch from the TFTP server

rommon 6>tftpdnld

Other questions: is your new ios bigger then your available flash? What is in flash?

I have a 2950 somewhere, just have to go dig it up, will respond again with more details once I locate a switch to test with.

lancehino Thu, 01/31/2008 - 09:24

Please post the exact steps in your attempt to restore image. Sounds like you're missing a step


This Discussion