WAAS and Routers running HSRP

Unanswered Question
Jan 29th, 2008
User Badges:
  • Silver, 250 points or more

I am just in the process of deploying WAAS across our network. I have found that when the WAN router that is running WCCP has been configured for HSRP and is the active router i see the following

If I try and telnet to the HSRP standby address it does not connect and I get the following error message :

Jan 30 18:04:36.930 AU-Summ: %IP-3-LOOPPAK: Looping packet detected and dropped

-

src=172.16.33.254, dst=172.16.9.251, hl=20, tl=72, prot=47, sport=0, dport=0

in=GigabitEthernet0/0.9, nexthop=172.16.9.251, out=GigabitEthernet0/0.9

options=none

-Process= "IP Input", ipl= 0, pid= 82

-Traceback= 0x611B33C0 0x616A0FD4 0x616A11E0 0x616A1C14 0x616A1FE4 0x6168D09C 0x

6168E880 0x6168C384 0x6168C648 0x6168C704 0x6168C8A8


f I telnet to the actual router address then ok.


is this a Bug?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Richard Bradfield Wed, 01/30/2008 - 01:03
User Badges:
  • Silver, 250 points or more

just seen other question about HSRP and tried the

"egress-method negotiated-return intercept-method wccp' command but made no difference


see router interface configuration below


Note if no HSRP then no problem



interface Loopback0

ip address 172.16.33.254 255.255.255.255

!

interface GigabitEthernet0/0

description trunk to Cat 6509

bandwidth 100000

no ip address

duplex auto

speed auto

media-type rj45

negotiation auto

ntp broadcast

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 1 native

ip address 172.16.1.100 255.255.255.0

no snmp trap link-status

!

interface GigabitEthernet0/0.2

encapsulation dot1Q 2

ip address 172.16.2.250 255.255.255.0

ip wccp 61 redirect in

ip flow egress

no snmp trap link-status

!

interface GigabitEthernet0/0.3

encapsulation dot1Q 3

ip address 172.16.3.250 255.255.255.0

ip wccp 61 redirect in

no snmp trap link-status

!

interface GigabitEthernet0/0.5

encapsulation dot1Q 5

ip address 172.16.5.252 255.255.255.0

ip wccp 61 redirect in

ip pim sparse-mode

no snmp trap link-status

standby 5 ip 172.16.5.254

standby 5 preempt

service-policy input prec

!

interface GigabitEthernet0/0.6

encapsulation dot1Q 6

ip address 172.16.6.252 255.255.255.0

ip helper-address 172.16.5.228

ip accounting output-packets

ip wccp 61 redirect in

ip pim sparse-mode

no snmp trap link-status

standby 6 ip 172.16.6.254

standby 6 preempt

service-policy input prec

!

interface GigabitEthernet0/0.7

encapsulation dot1Q 7

ip address 172.16.7.252 255.255.255.0

ip helper-address 172.16.5.228

ip wccp 61 redirect in

ip pim sparse-mode

no snmp trap link-status

standby 7 ip 172.16.7.254

standby 7 priority 105

standby 7 preempt

service-policy input prec

!

interface GigabitEthernet0/0.9

description testlan for WAAS

encapsulation dot1Q 9

ip address 172.16.9.254 255.255.255.0

ip wccp redirect exclude in

no snmp trap link-status

!

Zach Seils Wed, 01/30/2008 - 06:48
User Badges:
  • Cisco Employee,

Richard,


The problem you are reporting is CSCsg30875. You can work around this issue by defing a redirect-list that denies traffic destined to the IP address(es) of the router itself.


Zach


Actions

This Discussion