2 ISP's

Unanswered Question
Jan 30th, 2008
User Badges:

Hi.

I need to ask you for a help and advice. I have got a problem with running my router 1812 with two IPS's ;(. First one is configured as a static IP (f.e. 1.1.1.1) and connected to FE0, the second one is configured as PPPoE and static IP address (f.e. 2.2.2.2) and connected to FE1. The rest of configuration is on the swich port number 9 where is connected a server which has got a public IP address from the pool of the first ISP (f.e. 1.1.1.10) and connected via VLAN. Into the swich port number 2, LAN (192.168.1.0/24) is connected and configured as other VLAN. The problem is I can`t do that all my server's traffic is going in and out via FE0 and the LAN's traffic is going in and out via FE1.

I can`t do any experiments now, because now the router is connected and used for my server so that connection can`t be inactive even for a while. The PPPoE connection is configured on the other device, because it didn`t want to work for me before and I didn`t have a time for experiments. Now I need to connect two links into one router.

I would like to please you to give me any advices in steps. I will write what I have done before and what didnt`t work for me. I don`t have any configuration file from when it didn`t work :( so I can only try to describe it in steps, what I exactly do below.


1. Configured FE1 as PPPoE and Dialer1 as dialing interface. Everything worked fine because address was assigned to the int Dialer1.

2. Configured FE0 as static IP and configured routing as ip route 0.0.0.0 0.0.0.0 FE0.

3. Configured VLANS.

4. Configured ACL's to match IP's from LAN for further route-map.

5. Configured route-map to match IP's from ACL's and set next hop to IP's of Dialer1 int. I tried to set it as VLAN IP's - no result. [I wasn`t sure here which hop should be set.]

6. Configured NAT to let local trafic in and out.

That didn`t work. Server was working, got acces to the internet but LAN not. LAN 'saw' only the neighbours (other PC's and pings the gateway on the router - 192.168.1.1).

Then I had an idea to configure PPPoE as "main" connection but when I wrote ip route to set default path via FE1, traffic in and out to server stopped working ;(.


I don`t know what else can I write. I hope everything is understood even a bit.


If someone have a good heart and decide to help I will be very pleased :-)


Best regards,

Jarek

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rick Morris Fri, 02/01/2008 - 08:07
User Badges:
  • Silver, 250 points or more

There is a lot of info here. I would like to break it down a little to understand what you need.


You have 2 connections and want them to terminate into one device?


On your internal network what are you trying to accomplish specifically?


What I read is that you want two seperate systems running into one device, one for use and one for experiments? Does that sound correct?


Do the 2 networks internally need access to one another?


What are the connection types from your providers?


thanks

jarekgrzabel Mon, 02/04/2008 - 05:21
User Badges:

Hi.

Thank You that you were interested in my topic :-).

I will try to describe it for you one more time to make it all clear for you.


I have 2 connections and I want to terminate them into one device.


My internal network must go out to the internet via only one operator (using NAT). The second operator must be only used by a server.


There are any separate system and any exmerimental system. I wrote I cannot do any experiments now becaues everything is connected and I couldn`t risk of loosing connection by a server. The thing is I have other router which is using now for a NAT and LAN, and now I have new device (Cisco 1812) which now is using only for a server, but it need to be used instead of that first router. Cisco need to be used for a server and for a LAN.


The networks need to have an access each other, but it`s no problem. Server has 2 NIC's.


Ehm... what do you exactly mean ? Topology or what ? First one is ADSL in Annex B with static IP (6mbps/1mbps). Second one is a business class network connection (5mbps/5mbps with SLA).


What do I need ?


A prepared configuration, or... better - steps which should I do to run my router with 2 connection working as I wrote above (frist connection only for LAN+NAT, second only for server - public).


Thanks for Your help.


Best regards,

Jarek

Rick Morris Tue, 02/05/2008 - 13:32
User Badges:
  • Silver, 250 points or more

2 connections

To make sure I can conceptualize

--

Provider 1 -------------| r |

| o |

| u |

| t |

| e |

Provider 2 -------------| r |

---


This is your external network


How many internal interfaces on the router?

How does the router connect to the internal network, LAN?


I believe I might understand but need to see it before I can provide feedback.

jarekgrzabel Wed, 02/06/2008 - 00:37
User Badges:

Hi. Of course I will try to "draw" that schema for you :).


The situation should look like that:

http://jarekg.risp.pl/cisco/network.pdf


The LAN station should be behind NAT (overload) and all trafic from LAN to internet and from internet to LAN should go through FE0 (PPPoE 6/1mbit).

All traffic from server to internet and from internet to server should go through FE1 (6/6mbit).


LAN is behind NAT (overload), server got a public IP from the same IP class/subclass as FE1 is.


For example. Addressing:

PPPoE

IP: 80.0.0.2

Gateway: 80.0.0.1

Mask: 255.255.255.252


Network connected to FE1:

IP: 90.0.0.2

Gateway: 90.0.0.1

Mask: 255.255.255.240


Server:

IP: 90.0.0.3

Gateway: 90.0.0.1

Mask: 255.255.255.240


Now I hope everything is clear :).


Thank You for help :).


Best regards

Jarek

Actions

This Discussion