cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
405
Views
0
Helpful
1
Replies

route-map clause action with match statements - is this true?

kennethsali
Level 1
Level 1

Please let us know if this is true or false.

When you have a route-map defining a clause with a deny statement on it and have an access-list that does not define anything, this route-map clause will not have any effect on the routes

eg.

!

route-map cisco deny 10

match ip address cisco

!

route-map cisco permit 20

set metric 20

!

ip access-list extended cisco

##implicit deny all##

!

This is because there is an implicit deny on the access-list and logically that will cause all traffic through the sequence to go on the next clause 20 and set metric to 20 for all routes.

However, if you have a similar scenario but do not actually define the access-list in cisco IOS 'ip access-list extended cisco' then the route-map logic will ignore that match statement and implicitly deny everything.

!

route-map cisco deny 10

match ip address cisco

!

route-map cisco permit 20

set metric 20

!

!

1 Reply 1

Edison Ortiz
Hall of Fame
Hall of Fame

You are correct.

Interfaces to redistribute with route-map

interface Loopback0

ip address 192.168.1.1 255.255.255.0

!

interface Loopback1

ip address 192.168.2.1 255.255.255.0

!

route-map information and ACL per your config

ip access-list standard cisco

permit 192.168.1.0 0.0.0.255

!

!

route-map cisco deny 10

match ip address cisco

!

route-map cisco permit 20

set metric 20

I'm using OSPF for this test

router ospf 1

log-adjacency-changes

redistribute connected subnets route-map cisco

network 10.0.0.1 0.0.0.0 area 0

!

Let's observe the OSPF database

sh ip os data

OSPF Router with ID (192.168.2.1) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count

192.168.2.1 192.168.2.1 250 0x80000002 0x0053F8 1

Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag

192.168.2.0 192.168.2.1 94 0x80000001 0x00FFC8 0

192.168.2.0/24 is being redistributed per the route-map.

Now, let's remove the ACL and check the database:

#conf t

Enter configuration commands, one per line. End with CNTL/Z.

(config)#no ip access-list standard cisco

(config)#do show ip os data

OSPF Router with ID (192.168.2.1) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count

192.168.2.1 192.168.2.1 349 0x80000002 0x0053F8 1

(config)#

HTH,

__

Edison.

Review Cisco Networking products for a $25 gift card