MoH Not work for Local Extensions

Unanswered Question
Jan 30th, 2008
User Badges:

Hello to All,

Here We have CCM PUB and SUB 5.1.2

I configure the MoH Server to provide Multicast MoH from the branch SRST Voice Gateway, this is working fine.

The Problem is: When I enable hold between 2 local extensions, the phone that must listen the MoH not linten anything, but if I make a call for the PSNT from the same extension, the MoH work with no problems.

For testing propouses I invert the MoH servers in the MRG. When I use the Multicast MoH Server, only PSTN Calls listen MoH, and when I use the MoH Server without Multicast, only local Extensions Linten the MoH.

Anyone already get a problem like this?


Regads

Tafari Lima

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dheavey30 Sat, 06/21/2008 - 08:57
User Badges:

I have had the exact same problem as this and spent hours looking at media resource groups and codecs on the gateway etc! I eventually assigned the gateway to the publisher MRGL and it started to work. Not ideal as the pub is across the WAN so music is streaming over the WAN now. I then disabled multicast on the Sub MRG and now the internal phones only get a tone on hold but at least the PSTN calls get music.

Have you found out why this happened yet or does anybody else know what could cause this? When I look at the MoH files management on the Sub it says for this file Conversion Completed. Do the audio files need to be loaded onto each UCM server seperately perhaps? Version is also 5.1.2


Any input appreciated

Thanks

DH

allan.thomas Sun, 06/22/2008 - 12:44
User Badges:
  • Blue, 1500 points or more

Ordinarily it is not necessary to enable IP Multicast when you configure MMoH on the gateway.


However, it maybe necessary if the voice-gateway is on a different subnet to the user voice vlan.


This would certainly explain why you are able to get MMoH on PSTN calls, and not IP Phone to IP Phone unless you dial the DDI.


If the gateway is in fact on a different subnet then you will need to enable multicast on your LAN including the gateway, and enable it on your respective voice vlans.


Hope this helps.

Allan.

Actions

This Discussion