Errors during COBRAS import

Unanswered Question
Jan 30th, 2008

I'm looking at the COBRAS tool as a way to consolidate two Unity 4 servers into one Unity 5 server. I'd like to use the same directory and message store so existing messages don't loose timestamps or unread status but I'm getting the following error on the resolve subscriber conflicts step

Extension Error! Could not find subscriber owner for DTMFAccessID

I'm not sure what this error means. I get the same error after deleting the subscriber from Unity and/or running the remove subscriber data tool on the selected subscriber.

According to the documentation I believe this should work

Any suggestions would be appreciated

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
kseraphine Wed, 01/30/2008 - 13:02

My bad, I didn't wait long enough for AD to synchronize after removing the subscriber.

I am able to add the subscriber now without issue.

Too many VMs running at once I guess.

lindborg Wed, 01/30/2008 - 13:10

yeah- the sync time will vary quite a bit depending on the local install - not much that you can do to predict it unfortunately.

kseraphine Wed, 01/30/2008 - 13:32

by the way, amazing tool. This will save me from recreating 70+ call handlers manually. Not to mention preserving private lists and message notifications.

kseraphine Thu, 01/31/2008 - 14:04

I'm doing some more lab testing with COBRAS today and out of 30 accounts I'm trying to import to the new server, one is giving me the same error. I don't think its a directory sync issue since I forced the DCs to replicate and I've let it sit about six hours now. I've compared the problem account to another account (that is not giving me the error) in adsiedit and both only show two ciscoEcsbu attributes with values.

The user does show up in the import list if I try to create a new subscriber importing from exchange in saweb. So it would seem that Unity does not see this account as tied to a different Unity server.

Can you tell me specifically what COBRAS is looking for when generating this error?


Markus Schneider Thu, 01/31/2008 - 17:52

Did you run DBwalker before doing the export? It sounds like on the backed up data, there was no parent object ID for the DTMF number. I.e. if you're familiar with the CUDLE tool, if you go in to the DTMFaccessID table and see if--for that number--it has a parentobjectid that is valid (just putting the mouse arrow over the row should show you what it's pointing to). But DBWalker should find that, too.

kseraphine Fri, 02/01/2008 - 07:08

I do see the extension in the DTMFAccessID table. The ParentObjectID points to an entry in the GlobalSubscriber table that does not actually exist in Unity (right clicking show error could not find subscriber for this object id).

DBWalker does not pick up on this. I've run it with Check for orphaned entries in the GlobalSubscriber Table and Remove invalid references from DTMFAccessID.

I'm using the most recent version of dbwalker. Any idea on how to clean this up?

shane.orr Fri, 04/18/2008 - 20:05

Did you ever figure this out. My attempt is erroring out on just about all of my users when I try to import via Cobras?


This Discussion