Strange issue with flash: on 2621xm

Unanswered Question
Jan 31st, 2008
User Badges:

After failed upgrade of IOS by RME (it was saying CRC error) I tried to copy .bin file manually but got the same error. Then I tried to erase the flash: but after successful erasing I could see strange output


kzatcis14#dir flash:

Directory of flash:/


No files in directory


16252924 bytes total (2860576 bytes free)


There was something occupying some space on flash:



but when I did



kzatcis14#dir /all

Directory of flash:/


1 -rw- 13392284 Jan 30 2008 15:42:22 +05:00 [c2600-ipbasek9-mz.124-12c.bin]


16252924 bytes total (2860576 bytes free)


it showed me IOS on flash:

IOS is ok, I could successfully restart router with such IOS.


How can I fix it?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
spremkumar Thu, 01/31/2008 - 04:24
User Badges:
  • Red, 2250 points or more

Hi


Did u try to erase and used squeeze command to clean up the ios which is marked up for deletion.


Or try deleting the ios file and use squeeze command to clean it up ?



regds


glen.grant Thu, 01/31/2008 - 04:32
User Badges:
  • Purple, 4500 points or more

You have to squeeze the flash after deleteing the file otherwise it does not recover the space.


"squeeze flash:" --- hit enter


agipkcolon Thu, 01/31/2008 - 04:34
User Badges:

I did both.. and the results of both commands were ok, but the situation is still the same.

spremkumar Thu, 01/31/2008 - 04:47
User Badges:
  • Red, 2250 points or more

Hi


you still have one option left with you which is manual copy of the .bin ios image file directly onto your flash using the CLI.


While doing so it will check up for the necessary space on the flash and ask for your confirmation to erase the existing file which you can choose and put the new ios onto the flash.


regds


agipkcolon Thu, 01/31/2008 - 04:56
User Badges:

In the first message I told that I tried already to copy it manually. it asked for permission to erase, and then copied file, but at the end it gives crc error.

spremkumar Thu, 01/31/2008 - 05:00
User Badges:
  • Red, 2250 points or more


is it possible to paste the error message you are getting over there ?


regds


agipkcolon Thu, 01/31/2008 - 05:29
User Badges:

here is the error I get when I manually copy .bin


kzatcis14#copy tftp://kzatacs02/c2600-ipbasek9-mz.124-12c.bin flash:

Destination filename [c2600-ipbasek9-mz.124-12c.bin]?

Accessing tftp://kzatacs02/c2600-ipbasek9-mz.124-12c.bin...

Translating "kzatacs02"...domain server (10.191.6.2) [OK]


Erase flash: before copying? [confirm]

Erasing the flash filesystem will remove all files! Continue? [confirm]

Erasing device... eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee ...erased

Erase of flash: complete

Loading c2600-ipbasek9-mz.124-12c.bin from 10.191.28.123 (via FastEthernet0/0): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

[OK - 13392284 bytes]


Verifying checksum... CCCCCCCCCCCCCCCCCCCCCCCCC invalid (expected 0xFB1E, computed 0x3B16)

13392284 bytes copied in 144.940 secs (92399 bytes/sec)



I can try to reinitialize Flash: through ROMMON, but this is the last thing I want to do.

spremkumar Thu, 01/31/2008 - 05:48
User Badges:
  • Red, 2250 points or more

Hi


Once you are done with the copying of IOS file can you exectue Verify checksum command manually fro the command prompt ?


Can you also try formatting the flash and try copying once again.


regds




agipkcolon Thu, 01/31/2008 - 06:00
User Badges:

As you can see I cannot verify flash:


kzatcis14#dir flash:

Directory of flash:/


No files in directory


16252924 bytes total (2860576 bytes free)

kzatcis14#verify flash:

Verify filename []?

?File name not specified

kzatcis14#



but there is file, but looks like it is hidden.


kzatcis14#dir /all

Directory of flash:/


1 -rw- 13392284 Jan 31 2008 18:26:31 +05:00 [c2600-ipbasek9-mz.124-12c.bin]


16252924 bytes total (2860576 bytes free)



there is no format flash: command for this type of flash: memory.

Actions

This Discussion