6506 line card failure?

Unanswered Question
Jan 31st, 2008

Have a 6506 running IOS Version 12.2(18)SXF8 connected to a 3750 running IOS Version 12.2(25)SEE3 via fiber. The setting for the interface on 6506 is interface GigabitEthernet1/3

switchport

switchport access vlan 123

switchport mode access

switchport nonegotiate

no ip address

speed nonegotiate

The setting for the interface on the 3750 is

interface GigabitEthernet1/0/25

switchport access vlan 123

switchport mode access

switchport nonegotiate

spanning-tree portfast

Currently the 3750 has a link light and shows port 25 connected (Note swithcport is turned on but it doesn't show when doing a sho run). The 6506 has no link light and shows port 3 not connected. Every once in a while the 3750 will put the port in err-disable. I tried setting both to speed nonegotiate and to no speed nonegotiate. Either of those give me no link lights on either machine. Ran a diagnostic and the line card passed. Never seen that speed nonegotiate option before so I don't know I may be using it wrong. Anyone have any tips on what the next troubleshooting step should be?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Thu, 01/31/2008 - 10:29

Based on the configuration provided, you have a speed/duplex mismatch.

The 6500 has autonegotiation disabled and the 3750 has it enabled.

I suggest you leave the port on the 6500 as is, and configure speed 1000 / full duplex on the 3750.

Do a shut and no shut on the respective interfaces and post back with results.

HTH,

__

Edison.

everestm Thu, 01/31/2008 - 18:04

Do you know what exactly is causing the port to err-disable?? You should be able to see it in the log, or run "show int status err-disable"

bilousand Fri, 02/01/2008 - 02:56

spanning-tree portfast is a realy bad idea on the link between switches. =)

jschweng Mon, 02/04/2008 - 10:23

Will try messing with these options today, I thought I had done this but I've been configuring so much equipment in the past few days I may not have, don't remember. Could you please elaborate on why spanning-tree portfast on these interfaces is a bad idea? Will post this afternoon on any results. Thanks!

bilousand Mon, 02/04/2008 - 10:36

Portfast is a feature configured on links to end-users, merely interface with portfast transits almost immediately to forwarding state. BPDUs never expected on this port. It will cause bridging loops and spanning tree instability if this link attached to the device which actively participate in spanning tree topology (bridge/switch). Depending on the global options configured on the switch (BPDU guard) when interface with portfast enabled recieves BPDU it will be transited into error disable state.

jschweng Mon, 02/04/2008 - 12:55

I guess I should have mention that there is no dual connectivity anywhere in the network. There are no redundant connections, everything is 1-to-1 so I didn't think that would need spanning-tree bpduguard but I'll try enabling that, and also disabling spanning-tree portfast to see if either help. Thanks to all for your help in this matter.

jschweng Mon, 02/04/2008 - 14:37

Well there's no dual connectivity anywhere in this particular network, no redundant connections anywhere. Turned off portfast anyway on the interface on the 3750 and still get the same result. Green link light and a sho int status of connected on the 3750 end and no link light what-so-ever and a sho int status of notconnected on the 6506 end.

bilousand Tue, 02/05/2008 - 02:39

If port is up on the one end and down on the other then it's a problem with the fiber, 3750 sees the light from the 6506 but not the other way around.

jschweng Mon, 02/04/2008 - 12:35

The 3750's interface is a gig fiber connection, so speed and duplex are 1000 and full. No options for otherwise. Haven't gotten anymore err-disables though so that's good.

Actions

This Discussion