CME Phone Firmware Flexibility

Unanswered Question
Jan 31st, 2008
User Badges:

I am in the process of designing a small CME system for my home (had some extra gear lying around) and I had a few questions when it came to phone firmware.


I am aware that CME is built into Cisco IOS versions including the IP-Voice, Advanced Enterprise Services, etc. versions. Likewise, I also know that for full functionality I need to supplement the IOS with phone firmware files (and optionally the GUI files If I choose). I have a C2610xm and I have Firmware version 12.4(9)T for it. According to the CME compatibility matrix the recommended phone firmware (that also happens to be bundled in the cme-basic tar file) that I have is P0030702T023 (for 7960/40). My question is that if I have access to newer phone firmware loads such as P00308000500 or P00308000400 can I upgrade my phones to these loads while still running CME 4.0(1) on my router? The reason I ask this is that on the compatibility matrix firmware versions such as P00308000500 are only supported for CME 4.2 etc.


I have seen some people who are indeed running a router with 12.4(9)T and have their phones running P00308000500, but I am wondering if any of you are familiar with any issues that might result from such a pairing? Is it generally preferable to run the phones on a newer firmware load, even if it is not listed in the compatibility matrix for a particular version of CME?


thanks!

barsky

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
paolo bevilacqua Thu, 01/31/2008 - 14:13
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, in short my recommendation is: ignore the compatibility matrix at your own risk, thing that doesn't mean you shouldn't experiment a bit.


For example, but specific to your question, running 8.0(x) on 7940-60 in a CME 4.1 system, randomly produces phone to go mute (no dialtone and other funny effects). While running the cisco-recommended 7.2.T23 does not exhibit the problem.


Another example, for a long time 8.0.3 was the latest for the 7912, but had the local directory broken. It was working in 8.0.2 but not before, then it has been fixed in 8.0.4!


The thing is that most phone FW has his own set of bugs, and sometime features. It is not always a good idea to always running the latest, as I've learned with time!


The very same is true with IOS. for example try running 12.4(11)XY because you want to support the latest 79x5 models. As soon you configure "telephony-service" you realize by the "debug string leftovers" that probably, it's an hurried choice ...


dmitrybarsky Thu, 01/31/2008 - 16:30
User Badges:

Thank you so much! This is exactly the kind of information I was looking for!

davetucker Mon, 02/04/2008 - 02:45
User Badges:
  • Bronze, 100 points or more

Barsky,


I would take the firmware compatibility matrix as a recommendation as it is published at the time of release. There are usually good reasons to use a later load such as increased security and resolved bugs. I personally have upgraded 7940/7960 firmware v8.0(5) to resolve issues experienced by a customer running Unified CME 4.0 default loads. I am not aware of, or have experienced, any issues with this approach.


Just a few things to bear in mind...

Unless there is a compelling reason to the contrary, I would not upgrade CME Firmware beyond what is supported in the latest release. This will hopefully help to avoid any incompatibility issues.

Phone Firmware is not easily downgradeable, as Cisco IP Phones use Phone Image Authentication: only a later load has the correct key to allow the firmware to be upgraded.


Hope this helps. If it does, please rate!


Regards,


Dave


dmitrybarsky Mon, 02/04/2008 - 05:53
User Badges:

Dave, thank you for the reply! You brought up an interesting question. You said that phone firmware is not easily downgradeable. I know that you can not downrade to an unsigned load once you have upgraded to a signed load (this started in version 5.0 I think). However, would you say there are problems up/downgrading between later signed versions, for instance going from SCCP 7.0(2) to 8.0(5) or vice versa. I have always thought that with the universal application loader its all just a matter of changing the phones config xml files and the loader would load the corresponding phone image.


thanks again for your help!


barsky

paolo bevilacqua Mon, 02/04/2008 - 06:27
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, 7.x to 8.x and vice-versa is not a problem, I've done that many times while troubleshooting "phone goes dumb" problems.

Actions

This Discussion