QoS - dscp matching and setting not working when together

Unanswered Question
Feb 1st, 2008
User Badges:

Hello,


I am implementing QoS for outgoing traffic on the ATM interface of a 876 router.


I am marking certain traffic entering the LAN interface with dscp=1 to differenciate from other traffic at the output policy of the WAN interface, and then resetting the dscp to default value before going to the output queue.


The problem is that the packets marked with dscp=1 are correctly identified, but they are not getting the dscp value reset, and so they are going to the output queue still marked with dscp=1.


...Class-map: qos_dscp_1 (match-any)

......66013 packets, 5124458 bytes

......5 minute offered rate 2000 bps, drop rate 0 bps

......Match: dscp 1

........66013 packets, 5124458 bytes

........5 minute rate 2000 bps

......QoS Set

........dscp default

..........Packets marked 0

......Queueing

........Output Queue: Conversation 42

........Bandwidth 15 (%)

........Bandwidth 76 (kbps)Max Threshold 64 (packets)

........(pkts matched/bytes matched) 66013/5124458

........(depth/total drops/no-buffer drops) 0/0/0



If I add another match condition of type protocol match or acl match, packets matching those get the dscp reset, only packets that match the dscp condition are not getting the dscp reset.

I am running IOS 12.4(15)T1, maybe this is a bug of this release or is something I am missing?


Thanks for any help.


Rui





  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
aravindhs Fri, 02/01/2008 - 09:27
User Badges:

Hi Rui


Could you share your inteface configs and also let us know if you are using any tunnelling/other features on the router.


cheers

arav

Actions

This Discussion