Tomcat Service Not starting CM 4.1.3 SR5d Subscriber

Unanswered Question
Feb 4th, 2008

I have a Unique problem the Tomcat Service Not starting from the Windows NT Services screen. I have other servers on the single cluster they all works.The customer is not aware how long was that not working.He has the problem in using Real Time Monitoring Tool on this box because of this service.

1. So how can I restart this. I tried with CLI and i could not find this service.

2. Is there a way to install only tomcat Service without affecting anything.

3. I see this error on the ISAPI.log file under tomcat folder.

jk_ajp13_worker.c (174)]: In jk_endpoint_t::connect_to_tomcat, failed errno = 61

[jk_ajp13_worker.c (587)]: Error connecting to the Tomcat process.

[jk_isapi_plugin.c (555)]: HttpExtensionProc error, service() failed

4. What version of Tomcat Service comes on installation of Call Manager 4.1.3. I doubt some JDK was loaded after the installation and it got overwritten some files in Tomcat folder and so it is not working. I saw another file from Apache Jakartha jk_ntservice.exe same like Tomcat.exe of 64k size..

5. Any Microsoft Hotfix or DST update could have afftected in last one year. How could i find this..If that is the case it should have affected other servers also..

Any help or clue is highly appreciated.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
gogasca Mon, 02/04/2008 - 11:38

Did u install CRA in this server and perhaps uninstall it?

Try Adminutility to see if passwords are synched.

Reinstalling CallManager

would be the only supported way.

If you want to take the risk...modify this key

HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\CallManager\Build

So if they are running 4.1.3 then change the Build string from 4.1(3) to

4.1.2 for example and then run the 4.1.3 installation...

Not Cisco TAC supported

mothiamalrajxyz Mon, 02/04/2008 - 12:37

Thanks for your reply.

1. I am not sure the CRA was installed at any time ans uninstalled.But i do not see any trace of files on the server.I see all java related parameters missing at (17 of them )HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tomcat and then under Parameters

2. You had mentioned Not TAC suported. This is for Cisco Tomact Service or for reinstalling the whole stuff.

3. I also see some funky errors while trying to access CCM Admin page.

The Java Runtime Environment cannot be loaded from <\bin\hotspot\jvm.dll>

and then IE explorer error screen appears when you click OK on this error message.So CCM page also does not load.

So all these things are interrelated ?

gogasca Tue, 02/05/2008 - 20:02

2.Reinstalling Tomcat

3. CCMAdmin uses IIS so it might be Java related.

If it is not critical I will go for the reinstall

mothiamalrajxyz Wed, 02/06/2008 - 07:55

I noticed yesterday CCMAdmin was opening.So we can rule out that.

I looked the event viewer log:

The description for Event ID ( 4097 ) in Source ( CiscoTomcat ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: RegQueryValueEx, The system cannot find the file specified.

I read the solution from Cisco for Tomcat service not starting.

So if i compare this doc and the event viewer log it says files from the c:\Program files\Cisco\Java\JRE can be matched with the working setup and then copied.I comapared with other Sub and all files are there.So if some files are missing in the registry , can I assume Jave Runtime environment installtion will do the magic.It is 137Mb after install so i am not sure where all it will write on the registry and is that totally responsible for Tomcat and what are its functionality in Call Manager.




This Discussion