LMS 3.0.1 Duplicate CS Device Discovery

Unanswered Question
Feb 4th, 2008

All of my remote WAN divices are being dicovered twice. Once as the IP and a second time as the hostname.

Devices here on this side of the LAN are displayed once with the hostname just as all devices were configured before I upgraded from 3.0 to 3.0.1.

Tried deleting and rediscovering devices, changing seed divices and other dicovery settings. No change.

Any thoughts? Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 02/04/2008 - 12:31

What discovery modules are you using? How do you have discovery configured in terms of address resolution? How do you see the devices being duplicated? That is, how do you know they are being discovered twice?

mchiaravalle_2 Mon, 02/04/2008 - 13:11

Hi,

Discovery module:CDP tryed CDP with Ping Sweep no change.

Address Resolution: Resolve by Name and/or Resolve by Sysname. No change either one.

In CS-->Device and Credentials-->Device management-->All Devices. Some devices are listed twice. Once by their IP and another time by their HostName. They are also listed twice int the CS DCR Device List Report.

in LMS 3.0 occasionally I'd see a duplicate device but once found I could delete it.

Thanks

Joe Clarke Mon, 02/04/2008 - 15:01

I'd like to see screenshots showing this duplication just to make sure we're on the same page. I don't see any duplicate addresses in my discovery reports.

mchiaravalle_2 Tue, 02/05/2008 - 10:19

I've attached a DCR Export. To explain this report, all 2811 routers and 3560 switches are duplicated. They are listed once by IP address and listed again by hostname.

For example (cpr-anchorage) is the same device as (192.168.110.2.

Attachment: 
Joe Clarke Tue, 02/05/2008 - 10:24

I think I'm beginning to understand what's happening here. In the Beginning, before CS Discovery was ever run, how were devices configured in DCR? Let's take cpr-anchorage as an example. What fields were populated for that device in DCR?

mchiaravalle_2 Tue, 02/05/2008 - 12:08

I'm not exactly sure where to find the info you're looking for. Within CS-->Devices and Credentials-->Device Management, I deleted all devices. This cleared the DCR Device List. I haven't done a new discovery yet.

Now CS-->Devices and Credentials-->Device Discovery Summary and the devices in DCR shows the correct number of devices, however the Display Name, Host Name and IP address all show the same thing, the IP address. I've attached the Update to DCR.

Attachment: 
Joe Clarke Tue, 02/05/2008 - 12:16

The old stuff would have to have come from your memory. But starting fresh is good enough. What I think is happening is that name resultion is getting in the way. Now that I see exactly what you're seeing, I can reproduce this in my lab.

CS Discovery is find device A in DCR. Device A is called 10.1.1.1. When Discovery runs, CDP reports that Device A is connected to Device B. The CDP address being advertised for Device A is 20.1.1.1. So, Discovery politely updates DCR with the "new" device. Now, if 20.1.1.1 resolved to device-A, DCR will now show the following in its device list report:

10.1.1.1 Cisco 3745 Multiservice Access Router

device-A Cisco 3745 Multiservice Access Router

The workaround is to pick the correct name resolution scheme, or add:

cdp source-interface INTERFACE

To each device so the same address is always used for a given device. The fix might be very complicated.

nriaz Wed, 02/06/2008 - 14:51

what can we do if the router OS does not support cdp source-interface command. Also I can make all the interfaces resolve back to same name as you suggest in the other option. Is there no way to base it off the sysname parameter and get done with duplication.

Thank you

Nadeem Riaz

Joe Clarke Wed, 02/06/2008 - 17:22

Yes, you can make all of the IPs resolve back to one hostname, then make that hostname resolve back to the one management interface you want. The Discovery name resolution option is Resolve By Name.

mchiaravalle_2 Wed, 02/06/2008 - 16:24

I've been trying all the different device discovery settings in CS. I was able to fix the double discovery issue, but now the problem has changed. Seems I have a mix of some devices displaying IP and some displaying hostname.

If I go to CS Device Management and Edit Identity, any changes I make won't stick during the next Device Dicovery cycle.

Joe Clarke Wed, 02/06/2008 - 17:23

Uncheck "Update DCR Display Name" in your global Discovery settings. The manually configured DCR value should then stick.

Actions

This Discussion