Problems with dot1q trunk between 6509 (CatOS) and 3524XL

Unanswered Question
Feb 5th, 2008

I am having a problem with dot1q between a 6509 running CatOS 6.1, and a 3524XL.

Both sides are using vlan1 as the native vlan. The trunk ooks properly formed, and vlan pruning is also functioning properly.

I cannot ping form the 3524 to the default GW conigured on the switch. From a router in vlan 1, the arp entry for the IP configure on the switch shows incomplete. Using ISL everything works fine.

I am testing this 3524 using dot1q because I have a 2950 that supports only dot1q, and have the same problem with it.


#module 1 : 2-port 1000BaseX Supervisor

set udld enable 1/2

set trunk 1/1 on isl 1-1005,1025-4094

set trunk 1/2 nonegotiate dot1q 1-1005,1025-4094

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk


MilA3cat1> (enable) sh trunk 1/2

* - indicates vtp domain mismatch

Port Mode Encapsulation Status Native vlan

-------- ----------- ------------- ------------ -----------

1/2 nonegotiate dot1q trunking 1

Port Vlans allowed on trunk

-------- ---------------------------------------------------------------------

1/2 1-1005,1025-4094

Port Vlans allowed and active in management domain

-------- ---------------------------------------------------------------------

1/2 1-9,115,117,120,700

Port Vlans in spanning tree forwarding state and not pruned

-------- ---------------------------------------------------------------------

1/2 1,700

MilA3cat1> (enable)

mil1sw04#sh int gi 0/2 switchport

Name: Gi0/2

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: 1-9,115,117,120,700

Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none


ISL trunks for fine.I am currently testing with a 3524 using dot1q

Any ideas?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
owillins Mon, 02/11/2008 - 07:29

If two switches are in different VTP domains and trunking is desired between them, you must configure the trunk mode as ON or NONEGOTIATE on both sides in order to allow the trunk to come up without DTP negotiation agreement. In other words, this setting forces the link to be a trunk link.

ziutek Mon, 02/11/2008 - 07:50

The trunk port on the Cat6509 side is already set to nonnegotiate.

The switches are in the same VTP domain as well.

The trunk seems to come up fine. It's just that I cannot access the IP configured for management, which is vlan 1.

ziutek Mon, 04/21/2008 - 02:16

Just in case someone stumbles across this.

Someone had configured:

set dot1q-all-tagged enable

on the 6509. This causes all native (untagged)packets to be dropped, so any communication over vlan 1, which is our management vlan, were dropped. This explains why all other vlan traffci was uneffected.

resolution is: set dot1q-all-teagged disable

which is the default.


This Discussion