Problem adding new VRU PIM on IPCC 7.2(3)

Answered Question
Feb 5th, 2008

Hi,

I have a problem adding a new IPIVR PIM in an IPCC deployment with an IPIVR working fine.

My systems is made of two proggers. I have IPCC version 7.2(3). I have got a Generic PG with one CallManager PIM an another VRU PIM working fine.

I have added on the PG a new PIM for the new IPIVR (pim3). When I run the PG, I can see the three PIMs, but the new PIM doesn't try to connect the IPIVR. In the PG opc process I notice that the system can only see PIM1 and PIM2, but not PIM3.

Can anyone help me with this issue?

Regards,

Juan Luis

I have this problem too.
0 votes
Correct Answer by rbua about 8 years 10 months ago

Helping the current TAC SR owner on this ;-)

Provided action plan should address it.

Cheers,

Riccardo

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Zin.Karzazi Tue, 02/05/2008 - 04:26

Any Eventviewer Errors on the PGs? Can u post some traces using Dump Utility. Also post logs from your IPIVR.

lpezj Tue, 02/05/2008 - 04:50

Hi,

The IVR PIM doesn't try to connect to the IPIVR. so there are no logs on the IPIVR.

The opc process can see a pim1 and a pim2 process, but it can not see a pim3.

Regarrds,

Juan Luis

rbua Tue, 02/05/2008 - 05:08

Hola Juan Luis,

try this:

Increase the following registry setting for VRU pim

Vrudata\dynamic\sessionopentimeout (seconds) from 10 -> 60

If this is not enough collect PIM3 and NM logs and raise a TAC SR please.

Regards,

Riccardo

lpezj Tue, 02/05/2008 - 05:45

Riccardo,

I have tried your suggestion without success. I have one case opened with the TAC.

Thanks for your help,

Juan Luis

lpezj Tue, 02/05/2008 - 06:16

Riccardo,

I have tried your suggestion without success. I have one case opened with the TAC.

Thanks for your help,

Juan Luis

adam.jackman Tue, 02/05/2008 - 05:08

Have you added each of the PIM's from the ICM setup application as well as from PG Explorer?

Can you post a screen shot of PIM3 as it starts?

Have you looked in the PG OPC logs to see if there are any messages about the connection failing?

Adam

lpezj Tue, 02/05/2008 - 05:33

Hi,

I have checked your suggestions and all it seems to be right.

Here it is the PIM log:

14:29:57 Trace: PimConfig::ConfigLock: ChkDdLck=1 TrkLck=1 Grp=0 Ord=0 MxHldTcks=3000

14:29:57 Trace: PimConfig::CallLock: ChkDdLck=0 TrkLck=0 Grp=0 Ord=10 MxHldTcks=100

14:29:57 Initializing Event Management System (EMS) Library.

14:29:57 Trace: EMS Server pipe bmw\PG1A\pim3EMSPipe enabled for bmw\PG1A\pim3

14:29:57 Trace: Monitor Server pipe bmw\PG1A\pim3CmdPipe enabled for bmw\PG1A\pim3

14:29:57 Initializing Node Manager Library.

14:29:57 VRUPIM Release 7.2.3.0 , Build 20234

14:29:57 Trace: DSCP value used for QoS is 24

14:29:57 Failed to read AutoCfgErrorFileMaxBytes value in the SOFTWARE\CISCO SYSTEMS, INC.\ICM\bmw\PG1A\PG\CurrentVersion\PIMS\pim3\VRUData\Dynamic key in the registry.

14:29:57 Failed to read AutoCfgErrorFileName value in the SOFTWARE\CISCO SYSTEMS, INC.\ICM\bmw\PG1A\PG\CurrentVersion\PIMS\pim3\VRUData\Dynamic key in the registry.

14:29:57 Trace: PimConfig::TPServices: ChkDdLck=1 TrkLck=1 Grp=0 Ord=10 MxHldTcks=3000

14:29:57 Trace: EMT I/O completion ports: max threads=2, concurent threads=0

14:29:57 Connection to MDS process established.

14:29:57 MDS now in service.

When the opc starts there is a message regarding pgag, pim1 and pim2 are OK. There are no references to pim3, the new one.

Regards,

Juan Luis

rbua Tue, 02/05/2008 - 05:55

Juan Luis,

node manager or OPC should say something if not, try increasing the tracemask.

Suerte,

Riccardo

Correct Answer
rbua Tue, 02/05/2008 - 08:57

Helping the current TAC SR owner on this ;-)

Provided action plan should address it.

Cheers,

Riccardo

lpezj Tue, 02/05/2008 - 10:18

Riccardo,

Customer has provided a maintenace window tomorrow from 08:30 to 09:00.

I will try the suggested plan.

Regards and thanks a lot for your help. I will post the results.

lpezj Wed, 02/06/2008 - 02:07

Riccardo,

I have stopped the two sides of the PGs, I have added the third pim in the two sides and I have started the side A and after that the side B and now all works fine.

Thanks to you and Goran for the help.

Regards,

Juan Luis

sandeep pokhriyal Tue, 04/14/2009 - 07:12

Hi,

i am facing the same problem. i have two PIMs and both are not coming up.

i am getting same error on the PIMs.

can you please explain me the troubleshooting procedure.

thxx

Hi Sandeep216,

I've seen this problem before and I think it's due to the fact that the PGs share seetings in a duplex pair and so if you make a change to a live system the 'other side' overwrites the registry settings say that it's in control and will not allow the new settings to take affect. Try this:

Make sure you have configured the new PIM into Configuration Manager.

Stop both sides of the PG (if duplex)

Run ICMSETUP on side A

Add the new PIM

Complete SETUP

Run ICMSETUP on side B

Add the new PIM

Complete SETUP

START Side A

START Side B

Hope this helps.

Thanks

Dan

sandeep pokhriyal Wed, 04/15/2009 - 02:40

oh i forgot to mention the call server is not coming up.

i think this is the problem..

the voice browser log is here.

13:15:08 Initializing Event Management System (EMS) Library.

13:15:08 Trace: EMS Server pipe Customer\Voice Browser\VBEMSPipe enabled for Customer\Voice Browser\VB

13:15:08 Trace: Release 7.0.1, Build 1190

13:15:08 Trace: INFO: Registry base = CVP\Customer\Voice Browser

13:15:08 Trace: INFO: Process Name = VB

13:15:08 Trace: INFO: ICRRoot = C:\Cisco\CVP\bin

13:15:08 Initializing Node Manager Library.

13:15:08 Trace: INFO: Voice Browser Reading Registry...

13:15:08 Trace: Monitor Server pipe Customer\Voice Browser\VBCmdPipe enabled for Customer\Voice Browser\VB

13:15:08 Trace: Monitor Server pipe Customer\Voice Browser\VBReadOnlyCmdPipe enabled for Customer\Voice Browser\VBReadOnly

13:15:08 Trace: INFO: Voice Browser initializing globals...

13:15:08 Trace: INFO: VBRegistry::SetRegNotify Setting Registry trace

13:15:08 Trace: INFO: Voice Browser starting threads...

13:15:10 Trace: INFO: Resolving IP address for ICMGRPCVP1

13:15:12 Trace: INFO: IP address for ICMGRPCVP1 is 10.20.20.60

13:15:12 Trace: INFO: Gatekeeper configured is 10.20.61.92;SIDEA;1719. Registration attempts will start with first GK in this list until a successful registration occurs

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: maxCalls(defined in radvision config as Q931.maxCalls) = 1400

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: maxIVRPorts = 130

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: maxTotalCalls = 555

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: takebackPercentage = 0

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: startingRtpPort = 16384

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: radConfigPath = C:\Cisco\CVP\VoiceBrowser\Config.val

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: pktInterval = 20

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: adminMode = 1

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: RaiMaxThreshold = 90

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: RaiMinThreshold = 80

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: Codec = g711Ulaw64k

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: CpuMaxThreshold = 99

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: CpuMinThreshold = 94

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: CpuHealthCheck = 0

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: CpuSustainedTime = 15

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: CpuOverloadReject = 0

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: PerfmonIntervalTimer = 5000

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: MemMaxThreshold = 80

13:15:12 Trace: INFO: H323CallMgr::getRegistrySettings: MemMinThreshold = 60

13:15:12 Trace: INFO: Voice Browser Main Thread Active...

13:15:12 Trace: INFO: H.225 Call signalling address of Voice Browser is 10.20.20.60:1720

13:15:12 Trace: INFO: Voice Browser Trace Mask is 0x101083

13:15:12 Trace: INFO: Initial registration with gatekeeper

13:15:12 Voice Browser communication to the Gatekeeper successful, alarm cleared.

13:15:12 Trace: SYSLOG: Server: STATUS=2, Port: =H323,NAME=H.323Ser?+wSTATUS=2

13:15:12 Trace: INFO: H323CallMgr::sendRAI: Successfully sent RAI for resource unavailability

13:15:12 Trace: INFO: LongPoll Failed -- Got OUT_OF_SERVICE from Call Server

13:15:13 Trace: INFO: Starting HEALTH long poller to Call server localhost:8000/cvp/VBServlet

13:15:13 Voice Browser to Call Server localhost:8000 connection unsuccessful.

13:15:13 Voice Browser cannot access any Call Servers and is no longer accepting calls.

13:15:13 Voice Browser ICMGRPCVP1 is out of service.

13:15:13 Trace: INFO: H323CallMgr::sendRAI: Successfully sent RAI for resource unavailability

Actions

This Discussion