CME UC520 Configure FXS port

Unanswered Question
Feb 5th, 2008

Hi, I'm having trouble getting a normal analogue phone to ring or get a dial tone when connected to a FXS port on a UC520. I've gone back to a default configuration for the device and would appreciate any help I can get.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Tue, 02/05/2008 - 04:55

Hi, if no dialtone with default config, the port may got stuck, so reload the unit.

Then check that you're better running XW5 as older versions can be buggy in various areas.

craig.corbett Tue, 02/05/2008 - 05:29

I'm not sure if it's a pinout issue with my UK analogue phone. When I dial the analogue phone from an IP phone, the IP phone seems to ring the analogue phone but no ringing on the analogue phone though. When I pickup the analogue phone I can then hear a noise that matches the IP phone dialling but with no voice communications. Does this makes cense ?

craig.corbett Wed, 02/06/2008 - 06:50

I'm using a straight through RJ11 cable and another phone with a default config of the UC520 still nothing.

Robert Salazar Wed, 02/06/2008 - 07:05

enable 'debug vpm signal' to see if the port recognizes any activity when you go off hook.

Also check the output of 'show voice port summ' to see if those fxs ports are operational.

craig.corbett Fri, 02/08/2008 - 02:38

It seems that there is no activity when I plug my analogue phone into a voice port. No information is displayed after going off hook when debug vpm signal is active. This is what I get when I do a show voice port summ.


============== == ============ ===== ==== ======== ======== ==

0/0/0 -- fxs-ls up dorm on-hook idle y

0/0/1 -- fxs-ls up dorm on-hook idle y

0/0/2 -- fxs-ls up dorm on-hook idle y

0/0/3 -- fxs-ls up dorm on-hook idle y

Any suggestions ?

Paolo Bevilacqua Fri, 02/08/2008 - 02:43

Hi, stuck ports can do strange things, have you reloaded the box ? Have you upgraded to XW5 ?

craig.corbett Fri, 02/08/2008 - 02:46

Yes its been reloaded. Yes running XW5:

Cisco IOS Software, UC500 Software (UC500-ADVIPSERVICESK9-M), Version 12.4(11)XW


Robert Salazar Fri, 02/08/2008 - 08:46

with debug vpm signal enabled, issue 'term mon' if you're accessing the uc via telnet.

Then take the handset off hook.

See if anything shows up.

Try this on all the fxs ports.

craig.corbett Mon, 02/11/2008 - 01:05

Hi, I have tried his on all ports. I'm connected via the console port. First I did a no shut on the ports then tried the phone in all fxs ports and get noting. When I do a no shut before trying to go off hook I get this and nothing else:

UC520(config)#voice-port 0/0/0

UC520(config-voiceport)#no shut


Feb 11 08:56:59.319: htsp_process_event: [0/0/0, FXSLS_ONHOOK, E_HTSP_IF_INSERVI


craig.corbett Fri, 02/22/2008 - 04:34

Some new developments on this issue that is still on going. Would really appreciate any help on this.

When I do:

test voice port 0/0/0 relay ring on

The phone doesn't ring, but I get the ringing type noise when I lift and put the receiver to me ear?

Paolo Bevilacqua Fri, 02/22/2008 - 04:52

Hi, I think you're using a BT phone that is wired in some special British way.

Can you make sure only two central wires are going from router to phone, all other are cut off.

craig.corbett Fri, 02/22/2008 - 06:31

I'm not 100% sure that this is the issue, but I would like to get hold of an adaptor to try to make sure.

I'll try an get hold of one and post back the results.



craig.corbett Mon, 03/03/2008 - 06:37

Have got hold of a basic non BT phone still no luck. When I call the Analogue phone, the LED lights on the FXS port but nothing happens with the phone?

Paolo Bevilacqua Mon, 03/03/2008 - 06:39

If you lift, can you talk?

If so, seems like the ring generator is not working in which case the card would need to be replaced.

Paolo Bevilacqua Mon, 03/03/2008 - 12:16

You say that when you call it the led phone lights, so in some wat it does exist. You can send output of "debug vpm signal" when trying to use it.

craig.corbett Tue, 03/04/2008 - 00:41

I've tried the debug before with no joy; I'm suspecting it's the cable now. I'm in the uk and using the straight through Rj11 with the two centre pins being used. I'm suspecting now that this shouldn't be the case?

Paolo Bevilacqua Tue, 03/04/2008 - 02:15

That is the right cable.

Why don't you try an IOS upgrade to XW6 ?

You case is so strange than anything can be beneficial.


This Discussion