2651XM, 2FXO into Toshiba PBX gives one way audio

Unanswered Question

Hi All,


I've been scouring the boards for days with no success.


I've got a Cisco 2651XM with a 7940G hanging off one side, and a 2FXO port card plugged into an analog extension of a Toshiba CIX 100 PBX (in the UK).


I've configured the router as below, but when I call the analog extension from another phone plugged into the Tosh, the Cisco phone rings, and I can hear the person on the Cisco phone, but they can't hear me. Strangely, I can press the keypad and they can hear that, but they can't hear any speech.


Calling between the Cisco 7940 and IP communicator (the only two phones connected to the 2651XM) works fine.


Can anybody tell me what I'm doing wrong?


I know it's not an ideal setup (I'd rather use BRI but we don't control the PBX, getting it changed is to difficult currently, and this is proof of concept.


Layout:


Phone 1 >> Toshiba PBX >> FXO Port on 2651XM >> Phone 2 (Cisco 7940)


Config:


voice-port 1/0/0

supervisory disconnect anytone

cptone GB

timeouts call-disconnect 3

timeouts wait-release 3

connection plar opx 1000


dial-peer voice 1 pots

description Calls to internal numbers

destination-pattern 8....

port 1/0/0

forward-digits 4

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Robert Salazar Tue, 02/05/2008 - 08:23
User Badges:
  • Cisco Employee,

With an active one way audio call established, enter the following:

'show call active voice brief' on the gateway.

Enter this command a couple more times and see if the tx/rx counters are incrementing from each output.

This will give you a good idea on where the packets are failing.

If that looks good, place a call to the IP communicator instead to see if that has one way audio also.

Do you have any acl's configured?

See if udp port 2000 is being blocked anywhere.

Thanks for taking a stab at this.


Running the command gives the output attached, and it looks (to my untrained eyes) like both Tx and Rx counters are increasing.


Sho access-lists:


Standard IP access list 1

10 permit 192.168.50.0, wildcard bits 0.0.0.255

Extended IP access list 100

10 permit ip host 255.255.255.255 any

20 permit ip 127.0.0.0 0.255.255.255 any

30 permit ip 192.168.12.0 0.0.0.255 any

Extended IP access list 101

10 permit ip any any

Extended IP access list SDM_HTTPS

10 permit tcp any any eq 443

Extended IP access list SDM_SHELL

10 permit tcp any any eq cmd

Extended IP access list SDM_SSH

10 permit tcp any any eq 22


192.168.50.x is on Fe0/1 which is not used.


Both phones are hanging off Fe0/0 in the 192.168.12.x range.


Changing Voice-Port 1/0/0 to point at 1001 ( the IP communicator) gives exactly the same problem. Audio is one sided, but I can send DTMF tones from the remote phone and they show up on IP communicator.


I've also tried this with Voice-Port 1/0/1.


Could I have a bad card?


I've also swapped the cable between the FXO and the analogue PBX extension several times, no dice.


The previous analogue phone worked fine from this extension.


I've also tried a different analogue extension on the PBX with exactly the same result.



Attachment: 
Robert Salazar Tue, 02/05/2008 - 08:58
User Badges:
  • Cisco Employee,

from the show call active voice brief output, the tx: counter from the cme to the IP phone does not increment.


13A3 : 168 26166320ms.1 +2560 pid:1 Answer active

dur 00:00:34 tx:1707/286776 rx:1714/274240

Tele 1/0/0 (168) [1/0/0] tx:34270/34270/0ms g711ulaw noise:-55 acom:20 i/0:-55

/-67 dBm

13A3 : 169 26166350ms.1 +2500 pid:20003 Originate 1000 active

dur 00:00:34 tx:0/0 rx:1707/273120

Tele 50/0/1 (169) [50/0/1.0] tx:29520/29520/0ms g711ulaw noise:0 acom:0 i/0:0/

0 dBm



Could you check if the "ip source-address" config under telephony services is pointing to the int fe 0/0 IP address?


Also check if 'ip routing' is configured on the 2600.

conf t

ip routing


Let me know if this helps.

Robert Salazar Tue, 02/05/2008 - 09:21
User Badges:
  • Cisco Employee,

May need to look at your cme's config.

Try adding this to the config:


conf t

voip rtp send-recv

I've added that to my conf and it's not made any difference.


cronus#show run | include rtp

voice rtp send-recv

cronus#


Any other debugging commands I can run?


Do I need to dump my whole config out?


CME output:


cronus#show telephony-service

CONFIG (Version=4.0(2))

=====================

Version 4.0(2)

Cisco Unified CallManager Express

For on-line documentation please see:

www.cisco.com/univercd/cc/td/doc/product/access/ip_ph/ip_ks/index.htm


ip source-address 192.168.12.1 port 2000

load 7910 P00405000700

load 7960-7940 P0030702T023

max-ephones 10

max-dn 2

max-conferences 4 gain -6

dspfarm units 0

dspfarm transcode sessions 0

hunt-group report delay 1 hours

hunt-group logout DND

max-redirect 5

cnf-file location: system:

cnf-file option: PER-PHONE-TYPE

network-locale[0] GB (This is the default network locale for this box)

network-locale[1] GB

network-locale[2] GB

network-locale[3] GB

network-locale[4] GB

user-locale[0] US (This is the default user locale for this box)

user-locale[1] US

user-locale[2] US

user-locale[3] US

user-locale[4] US

srst mode auto-provision is OFF

srst ephone template is 0

srst dn template is 0

srst dn line mode is single

time-format 12

date-format mm-dd-yy

timezone 0 Greenwich Standard Time

secondary-dialtone 9

no call-forward pattern is configured.

no transfer-pattern is configured, transfer is restricted to local SCCP phones o

nly.

keepalive 30

timeout interdigit 10

timeout busy 10

timeout ringing 180

caller-id name-only: enable

system message Red Ant Ltd

web admin system name Admin

web admin customer name Customer

edit DN through Web: enabled.

edit TIME through web: enabled.

Log (table parameters):

max-size: 150

retain-timer: 15

create cnf-files version-stamp 7960 Jan 05 2008 16:59:58

transfer-system full-consult

auto assign 1 to 1

local directory service: enabled.

Actions

This Discussion