Phones stuck in configuring IP

Answered Question
Feb 5th, 2008
User Badges:

I have sevral phones at the site registering correctly. I hav three phones, of different models 7940, 7941, 7961 that are stuck in configuing Ip and will not pull an IP address. The phones establsih a cdp trust and are identified as a phone through cdp, however they will not pull an IP address from the dhcp server on the router. Other phones on the same switch have no issue. When I do a show cdp neighbor, this is my readout:

SEP001193D854BE Fas 0/14 172 H P Cisco IP PPort 1

SEP001193B6CE81 Fas 0/6 122 H P Cisco IP PPort 1

SEP00119332B799 Fas 0/18 165 H Cisco IP PPort 1

SEP001193B6CB89 Fas 0/4 179 H P Cisco IP PPort 1

SEP001192CD7E67 Fas 0/26 122 H P Cisco IP PPort 1

SEP0009B7542641 Fas 0/23 141 H P Cisco IP PPort 1

SEP000D299D449F Fas 0/9 132 H P Cisco IP PPort 1

SEP000D299D45B9 Fas 0/40 147 H P Cisco IP PPort 1

SEP000D28C21B51 Fas 0/34 126 H P Cisco IP PPort 1


The unit with the H only is the problem unit.

Correct Answer by Rob Huffman about 9 years 3 months ago

Hi Matt,


I just wanted to check to see if the Switchport config is any different for fa0/18 than the rest of the working ones?


Rob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Rob Huffman Tue, 02/05/2008 - 09:53
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Matt,


I just wanted to check to see if the Switchport config is any different for fa0/18 than the rest of the working ones?


Rob

Jaime Valencia Tue, 02/05/2008 - 10:17
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

do the ports have a voice vlan?

does the vlan configuration has the ip helper-address command if the DHCP server is not in the same subnet?


HTH

mattwbrown1 Tue, 02/05/2008 - 11:07
User Badges:

The config is the same, I did find the issue , finally. It turned out there were several ip addresses stuck in dhcp conflict on the router. I am not sure why. When I ran a simple show ip dhcp pool it indicated that only 64 addresses were taken, when I ran the show ip dhcp conflicts there were 49 in conflict with 19 addresses reserved I was out of addresses in the pool. I still do not know what caused them to go in to conflict, I cleared the conflict and bang the phones began to pull ip's. Go figure...

Hai Yue Wed, 02/06/2008 - 04:30
User Badges:

We have the same issue before, finally we solved it by adding the trick command : no ip dhcp conflict logging


DHCP address conflict :

An address conflict occurs when two hosts use the same IP address. During address assignment, DHCP checks for conflicts using ping and gratuitous ARP. If a conflict is detected, the address is removed from the pool. The address will not be assigned until the administrator resolves the conflict.


Cisco strongly recommends using database agents. However, the Cisco IOS server can run without them. If you choose not to configure a DHCP database agent, disable the recording of DHCP address conflicts on the DHCP server by using the no ip dhcp conflict logging command in global configuration mode. If there is conflict logging but no database agent configured, bindings are lost across router reboots. Possible false conflicts can occur causing the address to be removed from the address pool until the network administrator intervenes.



So without the command "no ip dhcp conflict logging", everytime there is a conflict, the conflict address will removed from the address pool. That means you will lost an available address from the pool. So day after day, you will lost more and more available address. Till one day, there is no more available address in the DHCP pool, the IP-phone can not get IP address lease.


Just add the global command "no ip dhcp conflict logging" in your DHCP pool device (we use Voice gateway Router as the DHCP Pool for IP-Phone), and that will solve the issues.


nrichie Wed, 02/06/2008 - 06:47
User Badges:

Are there any repercussions for implementing this command? It appears my client is having this problem.

Actions

This Discussion