Faxing issues on VG224

Unanswered Question
Feb 5th, 2008

I have about 15 different fax machines connected to a VG224 (various models). For some reason only the Brother 3800 models can not send (but they can receive).


The VG224 is configured with MGCP and the PSTN gateway is running H323. I've tried setting the fax rate in the MGCP config and pass-though on the H323 config. Does anyone have any other suggestions? Here are the configs.



************************VG224


voice-port range 2/0 - 23

alt-battery-feed feed2

!

ccm-manager redundant-host 10.10.10.1

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.10.10.1

ccm-manager config

ccm-manager config dialpeer-prefix

!

mgcp

mgcp call-agent 10.10.10.2 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax rate 9600

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

dial-peer voice 99920 pots

service mgcpapp

port range 2/0 - 23



********************PRI Gateway


voice service voip

allow-connections h323 to h323

fax protocol pass-through g711ulaw

h323

modem passthrough nse codec g711ulaw

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

codec preference 3 g729br8

!

voice class h323 1

h225 timeout tcp establish 2

!

dial-peer voice 1 pots

description **** PRI T1

destination-pattern 9T

fax rate disable

port 0/0/0:23


dial-peer voice 10 pots

description **** CAS T1

preference 1

destination-pattern 9T

fax rate disable

port 0/1/0:1

dial-peer voice 1001 voip

description **** Call Manager 2

destination-pattern [1-9]...

voice-class codec 1

voice-class h323 1

session target ipv4:10.10.10.2

incoming called-number .

dtmf-relay h245-alphanumeric

fax rate disable

no vad

!

dial-peer voice 1002 voip

description **** Call Manager 1

preference 1

destination-pattern [1-9]...

voice-class codec 1

voice-class h323 1

session target ipv4:10.10.10.1

incoming called-number .

dtmf-relay h245-alphanumeric

fax rate disable

no vad

!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hadbou Mon, 02/11/2008 - 08:03

Paste the following config:


1) show tech


2) debug voice ccapi inout ( for failed fax calls)

I have had zero luck getting the VG224 to work in both directions with MGCP.


We had MGCP on out PRi coming in and MGCP on the Vg224 setup with fax passthrough. We were able to fax out, at least from our test fax.


After spending a week with Cisco TAC and not gettting anywhere, I then converted the PRI gateway to H323 fax pass through. We were able to fax in, but not out.


I only had success by converting both to H.323.


Of course now mt ATAs will not work.

pcameron Tue, 02/12/2008 - 03:29

We see a lot of issues on later model faxes defaulting to a mode called SuperG3, which uses some T30 fax signaling modes, V8 modem call control signaling and V34bis modem tones to pass fax traffic at 33.6Kbps. It tends to mess up T38 fax relay for starters (on all brands of gear ... not just Cisco!).


Often the best thing is to go into config mode on the fax and find the config settings for "ECM - Error Correction Mode" and/or "V34/SuperG3 mode" and set them both to OFF. These have the effect of forcing the fax to go back to 'normal' T30 fax mode, which interoperates with the majority of fax machines.


Might be worth giving this a try on the Brother fax machine.

Actions

This Discussion