LMS 2.6 on Solaris 9: HTTP Status 500 - Internal Server Error

Unanswered Question
Feb 5th, 2008
User Badges:

Using j2re v1.4.2_12-b03 for months - no problems. Installed and ran a security policy check on system which required j2re v1.4.2 and above - used path to same runtime LMS was using. I am able to login to CiscoWorks but if attempting to access any program off CiscoWorks homepage (campus, rme, dfm, etc), I receive an http status 500 error message. Does j2re need to be re-installed and can it be done without re-installing the other LMS applications? Or is there something else wrong? Any help is appreciated. See the following error message for details.


HTTP Status 500 - Internal Server Error

type Exception report

message Internal Server Error

description The server encountered an internal error (Internal Server Error) that prevented it from fulfilling this request.


exception

javax.servlet.ServletException: Servlet execution threw an exception at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:193)...........

root cause

java.lang.NoClassDefFoundError

at javax.crypto.Cipher.a(DashoA12275)

at javax.crypto.Cipher.getInstance(DashoA12275)at com.sun.net.ssl.internal.ssl.SunJSSE_i.a(DashoA12275)at com.sun.net.ssl.internal.ssl.SunJSSE_bk.(DashoA12275).................................

Apache Tomcat/4.1.29


See attachment for complete error message.


Thanks - Ken.



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 02/05/2008 - 19:22
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You will need to post your NMSROOT/MDC/tomcat/logs/stdout.log. However, this has nothing to do with the Java plug-in. It most likely is caused by a corrupt installation or permissions problem. What changed recently that coincides with this error?

kviola1 Tue, 02/05/2008 - 21:46
User Badges:

Joe - the only thing that changed was an updated version of a homegrown security policy check program was installed which required jre 1.4.2. The program was supposed to be non-intrusive and would not make any changes to the system. It was applied to 6 Solaris 9 based CiscoWorks systems. Before the systems were booted, CiscoWorks worked fine but after each system was rebooted, this problem occurred. The error is exactly the same on each system. The program replaced a couple of files in the java security directory:


-rw------- 1 root sys 4355 Jan 31 16:33 US_export_policy.jar

-rw-r--r-- 1 root bin 2641 Mar 20 2002 US_export_policy.jar.orig

-rw------- 1 root sys 4368 Jan 31 16:33 local_policy.jar

-rw-r--r-- 1 root bin 3113 Mar 20 2002 local_policy.jar.orig


I don't think there are any other changes but there may be. See the attached stdout.log which has been sanitized.


Let me know what you think. Thanks - Ken.



Joe Clarke Tue, 02/05/2008 - 22:48
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This tool messed up CiscoWorks. All of the changes to the JREs under NMSROOT must be undone before LMS will work again. This means you must restore the original versions of those .jar files, and restart dmgtd. In the future, modify your tool not to touch CiscoWorks JREs. We release our own security patches to address published JVM vulnerabilities after they have gone through testing.


For reference, the JREs for LMS are located in NMSROOT/lib/jre and NMSROOT/MDC/jre. The perms on the resulting .jar files must be 0444 casuser:casusers.

kviola1 Wed, 02/06/2008 - 00:14
User Badges:

Joe - that worked very well. Thanks alot! Do you have any more ideas on the restorebackup issue?


Ken.

Actions

This Discussion