Unprocessed CallerID on CME

Answered Question
Feb 6th, 2008
User Badges:

Hi,


We have a trouble with CallerID. We receive it from the telco, but CallManagerExpress does not process it. Here's the debug log of a test call I made.


ISDN Se0/0/0:23 Q931: RX <- SETUP pd = 8 callref = 0x010D

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Facility i = 0x9F8B0100A11002010102010080084D4F4E415354204A

Progress Ind i = 0x8283 - Origination address is non-ISDN

Calling Party Number i = 0x2183, '450581xxxx'

Plan:ISDN, Type:National

Called Party Number i = 0x80, '2505'

Plan:Unknown, Type:Unknown

013118: Feb 1 20:48:41.921: ISDN Se0/0/0:23 Q931: TX -> CALL_PROC pd = 8 callref = 0x810D

Channel ID i = 0xA98381

Exclusive, Channel 1

ISDN Se0/0/0:23 Q931: TX -> ALERTING pd = 8 callref = 0x810D

ISDN Se0/0/0:23 Q931: TX -> CONNECT pd = 8 callref = 0x810D

ISDN Se0/0/0:23 Q931: RX <- CONNECT_ACK pd = 8 callref = 0x010D

ISDN Se0/0/0:23 **ERROR**: call_progress: DEV_CONNECTED VOICE ERROR: Bearer capability not available(0x3A): b channel 0 call id 0xBA

%ISDN-6-CONNECT: Interface Serial0/0/0:0 is now connected to 450581xxxx N/A

ISDN Se0/0/0:23 Q931: RX <- DISCONNECT pd = 8 callref = 0x010D

Cause i = 0x8090 - Normal call clearing

%ISDN-6-DISCONNECT: Interface Serial0/0/0:0 disconnected from 450581xxxx , call lasted 5 seconds

ISDN Se0/0/0:23 Q931: TX -> RELEASE pd = 8 callref = 0x810D

Feb 1 20:48:47.145: ISDN Se0/0/0:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x010D


See...


Facility i = 0x9F8B0100A11002010102010080084D4F4E415354204A

translates into

MONAST J


How can I tell CME to process those messages, and send them to the phones ?


Thank you!

Correct Answer by paolo bevilacqua about 9 years 5 months ago

Ok, I've found your previous message when the IE was not present at all. can you try:


voice service voip

qsig decode



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
paolo bevilacqua Wed, 02/06/2008 - 09:42
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, which switchtype have you confgured, and which exact IOS version ?

You should be able to see the name when all is allright.

olivier.bedard Wed, 02/06/2008 - 09:45
User Badges:

Cisco IOS Software, 3800 Software (C3845-SPSERVICESK9-M), Version 12.4(11)XJ4, RELEASE SOFTWARE (fc2)


isdn switch-type primary-5ess

As the telco's requirement.

paolo bevilacqua Wed, 02/06/2008 - 10:10
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Whoops, I had forgot. Please configure


isdn supp-service name calling


under inteface.


Hope this helps, please rate post if it does!

Correct Answer
paolo bevilacqua Wed, 02/06/2008 - 10:58
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Ok, I've found your previous message when the IE was not present at all. can you try:


voice service voip

qsig decode



Actions

This Discussion