AutoQoS on 1811

Unanswered Question
Feb 6th, 2008

I have a real problem. We have a client who uses an 1811 with a T1. I have the following config set up on their router, but they have a tremendous amount of choppiness and horrendous call quality. I will warn you that I'm not a VoIP or QoS guy at all, but I do the router configs, so any help would be VERY helpful!!

Their current config:

policy-map AutoQoS-Policy-Trust

class AutoQoS-VoIP-RTP-Trust

priority percent 70

class AutoQoS-VoIP-Control-Trust

bandwidth percent 5

class class-default



rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS

FastEthernet0/0 -


interface FastEthernet0/0

bandwidth 1536

service-policy output AutoQoS-Policy-Trust

Should I have AutoQoS enabled on the inside interface too??

Here's the result from sh policy-map interface:


Service-policy output: AutoQoS-Policy-Trust

Class-map: AutoQoS-VoIP-RTP-Trust (match-any)

9284026 packets, 2485060092 bytes

5 minute offered rate 9000 bps, drop rate 0 bps

Match: ip dscp ef (46)

9284026 packets, 2485060092 bytes

5 minute rate 9000 bps


Strict Priority

Output Queue: Conversation 264

Bandwidth 70 (%)

Bandwidth 1075 (kbps) Burst 26875 (Bytes)

(pkts matched/bytes matched) 11592/3099704

(total drops/bytes drops) 0/0

Class-map: AutoQoS-VoIP-Control-Trust (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: ip dscp cs3 (24)

0 packets, 0 bytes

5 minute rate 0 bps

Match: ip dscp af31 (26)

0 packets, 0 bytes

5 minute rate 0 bps


Output Queue: Conversation 265

Bandwidth 5 (%)

Bandwidth 76 (kbps)Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)

96205661 packets, 20675624476 bytes

5 minute offered rate 153000 bps, drop rate 0 bps

Match: any


Flow Based Fair Queueing

Maximum Number of Hashed Queues 256

(total queued/total drops/no-buffer drops) 0/0/0

Can anyone tell me what this means?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
m.batts Thu, 02/07/2008 - 06:40

First of all remove the policy from the fastethernet int and the bandwidth command as you don't really need them.I assume that the phones are on the same LAN as the router.If so what is it connected to and what is the config.



John Blakley Thu, 02/07/2008 - 07:43

Thanks for the quick reply!

This client connects to us through a VPN tunnel. Their call control is handled on the other end of the tunnel. Their phones are on the same LAN, but the gateway that they pull dial tone from is on our end (their terminating end-point). I was under the impression that the bandwidth statement has to be enabled on the egress interface for AutoQoS to do proper calculations. It applies the policy to the interface that AutoQoS is applied to.


This Discussion