AIR-AP1230B-A-K9 upgrade failure

Answered Question
Feb 6th, 2008
User Badges:


Hi all.

I am upgrading some AP firmware on our network. We are using a cross between AP350s, (which i keep telling them to get rid of), AP1200s, and AP1242s.

We still don't have a Wireless Lan Controller, so I have been upgrading my 650 APs individually, manually across the browser interface.

This is all done remotely across the country.


I have come into an issue where an AP1200 had 12.3(2)JA6 and I was attempting to upgrade to 12.3(8)JEA3. Generally all is well and this process takes only a few minutes. This time, it continued to retry..the little popup progress windows would restart quite often. Nothing seems to have happened as far as configuration goes, as I can still access the device through telnet. However when accessing it through the browser the screen reverts back to an old-school non-user friendly, non-gui interface that gives some help resources and an almost CLI style html linked access menu.


So it looks to me that the process made it partially through, just enough to mess up the browser interface.


My question is this...should I attempt to upgrade through the telnet session, which will likely result in 'not enough memory' errors, or is there a way to remedy this lovely turn of events?


Thanks in advance for any and all support.


Matt

Correct Answer by Rob Huffman about 9 years 5 months ago

Hi Matt,


Sorry Bro, another broken link :( This does have some good ideas in it (can you use the overwrite?);


http://www.cisco.com/en/US/docs/wireless/access_point/12.3_2_JA/configuration/guide/s32mfw.html#wp1035507


Hope this helps!

Rob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Rob Huffman Wed, 02/06/2008 - 10:28
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hey Matt,


Wow! This sounds like quite the task my friend. Have you seen this note (below);


Software upgrades fail when you use the web-browser interface to install Cisco IOS Release 12.3(8)JEA3 on 1200 series access points. The image size exceeds the access point's 4-MB restriction for software upgrades. Use TFTP to upgrade your access point to this release. For complete instructions on using TFTP to upgrade access point software, see the "Working with Software Images" section in the Cisco IOS Software Configuration Guide for Cisco Aironet Access Points. Click this link to browse to that document:


http://www.cisco.com/univercd/cc/td/doc/product/wireless/airo1100/accsspts/i1232ja/i1232sc/index.htm


From these Release notes


http://www.cisco.com/en/US/docs/wireless/access_point/ios/release/notes/12_3_8_jea3.html


Hope this helps! (Argghhh I know)

Rob

matthogue Wed, 02/06/2008 - 10:40
User Badges:

Thanks Rob. Yeah, its fun, just a bit technologically late for this size business.


I suppose I hadn't seen (or paid attention to) that notice yet. Strange that it works on quite a few of the 1200s. I'll do the tftp, but I believe it will fail again with a low memory error.


I'll let you know how it works. Thanks again!


matthogue Wed, 02/06/2008 - 10:55
User Badges:

So I tried the tftp update and it came back with %Error writing system:/running-config (Not enough space).


Do you have a link to a document for deleting unnecessary files to increase space?

And btw, the first link you gave before didnt have "Working with Software Images". :(

Correct Answer
Rob Huffman Wed, 02/06/2008 - 11:02
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Matt,


Sorry Bro, another broken link :( This does have some good ideas in it (can you use the overwrite?);


http://www.cisco.com/en/US/docs/wireless/access_point/12.3_2_JA/configuration/guide/s32mfw.html#wp1035507


Hope this helps!

Rob

matthogue Wed, 02/06/2008 - 12:03
User Badges:

Hey! Hey! Hey!


The overwrite worked. Muchos Appreciatos!


Rob, you are the man!!!

Rob Huffman Wed, 02/06/2008 - 12:10
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Matt,


You are always welcome my friend! Glad to be of some small help. Best of luck with this project.


Take care,

Rob

Rob Huffman Thu, 02/07/2008 - 06:44
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Matt,


I forgot to mention why you are seeing this problem in the 1230's and not 1240's. Look in the table in this doc and you will see that the 1240 has twice the available Flash. (32MB to 16MB)


http://www.cisco.com/en/US/prod/collateral/wireless/ps5678/ps6973/ps8382/prod_bulletin0900aecd806b8b6a_ps6108_Products_Bulletin.html


Hope this helps!

Rob

matthogue Thu, 02/07/2008 - 10:16
User Badges:

Thanks Rob.


But I have actually been able to do the update through the web interface on quite a few 1230 APs. I have only noticed a couple of the ones I did yesterday that were not able to go through the web interface...so if it is a size issue then maybe some of them didnt have large log files...??? Not sure, but I know I am moving forward a bit faster with this today thanks to you.


Thanks a bunch for your help. Grade A my man!!

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode