Clientless SSL VPN issues with RDP on ASA 5510

Unanswered Question
Feb 6th, 2008

I have some users that are using logging in to a Web portal on the ASA 5510 and then starting an RDP session to a server where they need access. They then run multiple apps within the RDP session (IE, Adobe, Excel, medical application) and keep getting a JavaRDP error which eventually freezes their window. I am using the current RDP plug-in from Cisco. Is there an issue with trying to run multiple applications from within the RDP session that would cause the Java RDP error? Could it also be the version of the JRE that is installed? We have tried multiple versions of the JRE from 1.4 to 1.5 and found issues. We know that 1.6 doesn't work with the current Plug-in. I received an interim plug-in release to address 1.6 but it seemed to be more unstable than the current version. Any and all help will be appreicated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
brosmitty Wed, 02/06/2008 - 19:55

On the web portal you should have an AnyConnect option. Install the AnyConnect client, then find it in Start Menu All Programs and create a desktop shortcut to it. Close your previous VPN connection, then connect to your VPN using this shortcut. Now RDP should work properly from the PC instead of through the web portal.

You should also check to be sure your ASA is updated to the latest version.

If AnyConnect is not an option for you, you will have to modify the SSL VPN options through the ASA console by publishing RDP and the java plug-in.

jdelrosario Wed, 02/06/2008 - 23:05

I an using the 8.0(3) version of the ASA. So did you have issues with RDP through the Web portal? I had installed the Java Plug-In and that may be what is causing the issue. It only works up to JRE 1.5 Update 13. 3 weeks ago, Cisco TAC had sent me an interim release Java Plug-In that is supposed to work with JRE 1.6.x, but it caused more issues when I tested it so I went back to the plug-in from last year. I'm still waiting for a response from Cisco on another TAC case I opened with a new interim release Java Plug-In. I didn't see an AnyConnect option when I was configuring the web portal..Is this the preferred method over the web portal for an RDP connection?

Where would I need to add that?

Thanks for your response.


This Discussion