Qos on subinterface

Answered Question
Feb 6th, 2008

Hi,

I have to put differnet QOS policies on 2 sub interfaces of my 7204 router, but I am getting the following message when applying,

TEST(config)#int pos4/0.72

TEST(config-subif)#service-policy output MPLS-Link

CBWFQ : Not supported on subinterfaces

TEST(config-subif)#

Please sugust how to solve this issue,

Regards,

I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 8 years 11 months ago

Ok, the map-class issue took us off-track and your problem is that you didn't change the config as I recommended back on my first post on February 6th.

You must configure a hierarchical policy with the shape command at the parent level. Use the bandwidth command for CBWFQ, or the priority command for Low Latency Queueing (LLQ) at lower levels.

Here is sample config that works

policy-map MPLS-Link

class VOIP

priority 10000

set dscp af31

class class-default

fair-queue

random-detect

!

!

!

policy-map MPLS-Sub

class class-default

shape average percent 75

service-policy MPLS-Link

On the subinterface, remove the map-class and apply service-policy output MPLS-Sub

__

Edison

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Edison Ortiz Wed, 02/06/2008 - 14:52

You must configure a hierarchical policy with the shape command at the parent level. Use the bandwidth command for CBWFQ, or the priority command for Low Latency Queueing (LLQ) at lower levels.

Posting the MQC configuration will sure help.

__

Edison.

guruprasadr Wed, 02/06/2008 - 20:38

HI Mohammed, [Pls RATE if HELPS]

Normally, the CBWFQ is not supported in Sub-interfaces of CISCO.

Create a Policy-map as Parent & match only "class class-default" in the Parent Policy-map. Then apply the "service-policy output MPLS-Link" inside the Parent Policy-map.

Finally, apply the "Parent" policy-map to the sub - Interface.

It should work....

PLS RATE if HELPS

Best Regards,

Guru Prasad R

mohammedrafiq Fri, 02/08/2008 - 08:33

Hi I habe applied as below but getiing differnet error when assigning policy map inside frclass,

TEST(config-map-class)#service-policy output MPLS-Link

I/f POS4/0.72 DLCI 16 class VOIP requested bandwidth 10000 (kbps), available only 28 (kbps)

TEST(config-map-class)#

----------

config,

policy-map MPLS-Link

class VOIP

priority 10000

set dscp af31

class class-default

fair-queue

random-detect

interface POS4/0

no ip address

encapsulation frame-relay

shutdown

frame-relay traffic-shaping

!

interface POS4/0.72 point-to-point

bandwidth 155000

ip vrf forwarding lite7200

ip address 1.1.1.1 255.255.255.252

frame-relay interface-dlci 16 IETF

class frclass

!

map-class frame-relay frclass

service-policy output MPLS-Link

I/f POS4/0.72 DLCI 16 class VOIP requested bandwidth 10000 (kbps), available only 28 (kbps)

Regards,

Edison Ortiz Fri, 02/08/2008 - 08:59

Let's see map-class frame-relay frclass portion of the config.

__

Edison.

guruprasadr Fri, 02/08/2008 - 20:35

HI Mohammed, [Pls Rate if HELPS]

Interface B/W of POS4/0.72 is only 155000

The requested B/W for class VOIP is 10000Kbps.

It means out of B/W=155000, only 28Kbps is left Un-used. Refer is there any Class map already using the more Bandwidth of the Interaface.

Refer: "map-class frame-relay frclass" and show the configuration.

PLS RATE if HELPS

Best Regards,

Guru Prasad R

mohammedrafiq Sun, 02/10/2008 - 05:03

Hi Guru,

I am only using this class map.my pos link is 155 M which I am using 10M for voice,Please see the remainning config below,

TEST#sh run

!

no ip domain lookup

!

ip vrf lite3600

rd 3600:1

!

ip vrf lite7200

rd 7200:1

!

ip multicast-routing

ip multicast-routing vrf lite3600

ip multicast-routing vrf lite7200

ip cef

appletalk routing

!

!

!

class-map match-any VOIP

match dscp ef

match ip precedence 5

match ip dscp ef

!

!

policy-map MPLS-Link

class VOIP

priority 10000

set dscp af31

class class-default

fair-queue

random-detect

!

!

!

i

!

interface FastEthernet3/0

ip vrf forwarding lite3600

ip address 192.1.1 255.255.255.252

shutdown

duplex half

!

interface POS4/0

no ip address

encapsulation frame-relay

shutdown

service-policy output MPLS-Link

!

interface POS4/0.36 point-to-point

bandwidth 30000

ip vrf forwarding lite3600

ip address 2.2.2.1 255.255.255.252

ip access-group Allowed-Nets in

frame-relay interface-dlci 17 IETF

!

interface POS4/0.72 point-to-point

bandwidth 155000

ip vrf forwarding lite7200

ip address 1.1.1.1 255.255.255.252

frame-relay interface-dlci 16 IETF

!

map-class frame-relay frclass"

Edison Ortiz Sun, 02/10/2008 - 07:25

You are missing the map-class from the post. This may be influencing your available bandwidth on the interface.

I don't recommend applying a service-policy on the interface along with a map-class. You should add the service-policy under the map-class as a child policy and apply the map-class on the interface.

HTH,

__

Edison.

mohammedrafiq Sun, 02/10/2008 - 10:02

I have took off the service policy from the interface and applied on sub interface and getting the error when assiging policy to map-class,

interface POS4/0.72 point-to-point

bandwidth 155000

ip vrf forwarding lite7200

ip address 1.1.1.1 255.255.255.252

frame-relay interface-dlci 16 IETF

class frclass

!

map-class frame-relay frclass

service-policy output MPLS-Link

I/f POS4/0.72 DLCI 16 class VOIP requested bandwidth 10000 (kbps), available only 28 (kbps)

Edison Ortiz Sun, 02/10/2008 - 10:39

And we are still unable to see what's contained on the map-class.

The reason you haven't post it is due to confidential information (not sure how confidential can be a map-class) or you aren't understanding what I am asking for?

I also don't know what other interfaces are under POS4/0 as they also consume the allocated bandwidth. The bandwidth is assigned to the main physical interface, not the subinterfaces.

__

Edison.

mohammedrafiq Sun, 02/10/2008 - 12:38

hi,

The resason you cant see anything in map-class cos,at present nothing contained in map-class, cos as soon as I try to attach service-policy in class-map it trough error message and does not attach service-plicy to frame- class as below,

conf t

TEST(CONFIG)# map-class frame-relay frclass

service-policy output MPLS-Link

"Error"

I/f POS4/0.72 DLCI 16 class VOIP requested bandwidth 10000 (kbps), available only 28 (kbps) ,

I have moved the b/w command from subint, I have 2 subint under physical pos4/0.

interface POS4/0

no ip address

encapsulation frame-relay

shutdown

!

interface POS4/0.36 point-to-point

ip vrf forwarding lite3600

ip address 2.2.2.1 255.255.255.252

ip access-group Allowed-Nets in

frame-relay interface-dlci 17 IETF

!

interface POS4/0.72 point-to-point

ip vrf forwarding lite7200

ip address 1.1.1.1 255.255.255.252

frame-relay interface-dlci 16 IETF

!

map-class frame-relay frclass"

Edison Ortiz Sun, 02/10/2008 - 13:01

Please post the output from typing

sh queueing interface interface POS4/0

sh frame pvc 16

sh frame pvc 17

sh interface POS4/0

__

Edison.

mohammedrafiq Sun, 02/10/2008 - 13:28

Hi,

This router has not been connected to network yet, I am middle of building it, so output of these commands does not show much.

Regards,

Correct Answer
Edison Ortiz Sun, 02/10/2008 - 13:31

Ok, the map-class issue took us off-track and your problem is that you didn't change the config as I recommended back on my first post on February 6th.

You must configure a hierarchical policy with the shape command at the parent level. Use the bandwidth command for CBWFQ, or the priority command for Low Latency Queueing (LLQ) at lower levels.

Here is sample config that works

policy-map MPLS-Link

class VOIP

priority 10000

set dscp af31

class class-default

fair-queue

random-detect

!

!

!

policy-map MPLS-Sub

class class-default

shape average percent 75

service-policy MPLS-Link

On the subinterface, remove the map-class and apply service-policy output MPLS-Sub

__

Edison

Actions

This Discussion