delay dialing international numbers

Unanswered Question

Good afternoon everyone.

We are having an issue that is only present when dialing international calls.

There is about 15 seconds delay when I dial an international number. I changed the the T302 timer setting and it seemd to help a little bit. I am not 100% sure that this is the setting that I need to be looking at.

The delay is from the moment I dial the last digit to the moment that the call is realsed to the PSTN. Furthermore, if I dial the same number a second time, then there is no delay at all.


Call Manager 4.1(3) MGCP gateway.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
btmulgrew Wed, 02/06/2008 - 14:51
User Badges:

Hi - Try setting up a route pattern (no route filter or numbering plan) for the full dialled number and place a test phone in the same partition, place calls using this phone. This will establish if there is overlapping digits in your dial plan.


Cheers

well I think I understand the issue a little bit better, but I am not sure of what the best solution is.

I think I was correct on thinking that the t302 interdigit parameter could help the issue, and the route patter is functioning as expected. The fact that we don't dial the the same amount of digits for every international call causes the delay since the call is realeased after waiting the t302 time in case more digits are coming. Am I making myself clear? and Am I correct?

I cannot lower the t302 timing. In fact I had to increase it at one point so people did not complain about not having enough time to enter CMC among other reasons.

I wouldn't like to change route patters to make people change the way they dial international numbers.

I finally found some threats on this most of which suggest adding maybe a # at the end.

Any other suggestions?

thomasarun Thu, 02/07/2008 - 04:11
User Badges:

I think u r correct put # in RP and select #trailing in discard digits

pcameron Thu, 02/07/2008 - 04:54
User Badges:
  • Cisco Employee,

Normal reason this happens is that for international calls, the international exchange the gateway is connecting to has no idea of how many numbers are needed to route the call - they see the leading international access code and more numbers come in via the initial ISDN Q931 setup message. Unless the "SENDING COMPLETE" flag is set in the outgoing setup message, the exchange will assume the call is overlap and more digits may follow, so it waits for more digits to come in via subsequent Q931 facility IE's. The CCM sees no call proceeding message and after 10 seconds it drops the call.


The fix is to set the CCM service parameter 'Sending Complete Indicator" so the CCM includes the sending complete flag in the outgoing setup message - this tells the exchange there are no more digits to follow and the call should be processed immediately.



Jaime Valencia Thu, 02/07/2008 - 14:47
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

what route pattern do you use?

if you have 9.@ the pattern CUCM uses something like this 9(01)(1)(xx)(x+)


CUCM knows that it's going to be an international call by the 01, a direct call by the 1 and then the 2 digit country code, the last statement (x+) means at least one digit or more


CUCM DOES NOT KNOW ALL THE DIAL PLANS FROM AROUND THE WORLD


it only knows how to recognize the international call by the first digits


if you live in a country where only 10 people live you only need 1 more digit after the country code


this behavior is caused because your call may require 10,12,15,16,17, etc digits

CUCM has no idea how many digits you need to make the call, so it waits until the IDT expires or the user presses #


if you want to expedite the calls make specific patters for the countries you call the most (assuming they have a uniform dial plan) for example germany does not have a uniform dial plan like the NANP


if you want to expedite the calls have the users press # or have them wait if there is no way to create a specific route pattern


HTH

pcameron Thu, 02/07/2008 - 19:51
User Badges:
  • Cisco Employee,

Normally for CCM and international calls you have no idea of how many digits will be used, so most customers use a route pattern of 9.011! to allow the interdigit timeout to expire after the digits have been dialed.


Are you users just having an issue with this interdigit timeout? You can chnage this by adjusting the T302 timer under the service parameters. The T302 timer is the only service parameter that can adjust the

interdigit timeout length for ip phones registered to CCM. It will take

effect if you have route-patterns with variable length wildcards like

"!"


You can also use the # key to force immediate dial but this requires an

additional route-pattern to match the # eg 0.0011! # . You'll also need to make sure Strip # Sign from Called Party Number* service parameter is enabled to TRUE.

Otherwise , for the sending complete question, I got my commands wrong. From CCM version 4.0, there is a check box in the Route Pattern config screen called 'Allow Overlap Sending'. When this check box is NOT checked, the outgoing ISDN Q931 setup message has the sending complete flag set, so the network should know there are no more digits to follow and the call should proceed.


Even if you Overlap Sending, it does not change the fact that CCM will still wait for the interdigit timeout value set in T302 timer before it completes the digit analysis process when there is a variable length

route-pattern such as '!'.


Make sure this option has not been enabled by mistake, otherwise can you get a 'debug isdn q931' trace from the gateway when you make an international call so we can see how long it takes to get a response from the service provider.

Thanks for your help.

My users are actually fine (sort of) Wwe have had ver little complains.

But we are about to rollout a fax application for outbaound faxing and here is wehere I am having trouble. The app times out before the interdigit time out expires. I think I will implement the # option and only direct them to use it when faxing. I don't want to introduce yet another change.

Thanks everyone for their input. I know understand much better not only this particualr issue, but more about RP and ISDN call setup.

I'll be running for CCVP the second half of the year, and this definitly helps.


Regards and have a good weekend.


Carlos.

Actions

This Discussion