Names not displayed on user phones

Unanswered Question

My VoIP implementation does not display the name of the calling party. The number is displayed, however, the name says "From Unknown Caller". I have validated with the carrier that our PRI circuits are configured to send through this information. How do I configure the gateway so that this information is displayed on the phones. I am running CallManager 4.1.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rajesh Revuru Thu, 02/07/2008 - 08:42
User Badges:
  • Silver, 250 points or more

Can you try turning on debu isdn q931 and see if what exactly carrier is sending.


Also, what gateway protocol are you using

Gateway protocol is MGCP. here's some of the debug isdn q931:


Feb 7 2008 12:26:27.406 EST: ISDN Se1/0:23 Q931: TX -> DISCONNECT pd = 8 callref = 0x9E4F

Cause i = 0x8090 - Normal call clearing

Feb 7 2008 12:26:27.566 EST: ISDN Se1/0:23 Q931: RX <- RELEASE pd = 8 callref = 0x1E4F

Feb 7 2008 12:26:27.602 EST: ISDN Se1/0:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x9E4F

Feb 7 2008 12:27:19.740 EST: ISDN Se1/0:23 Q931: RX <- SETUP pd = 8 callref = 0x0055

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Calling Party Number i = 0x2183, '5143268181'

Plan:ISDN, Type:National

Called Party Number i = 0x80, '5125'

Plan:Unknown, Type:Unknown

Feb 7 2008 12:27:19.796 EST: ISDN Se1/0:23 Q931: TX -> CALL_PROC pd = 8 callref = 0x8055

Channel ID i = 0xA98381

Exclusive, Channel 1

Feb 7 2008 12:27:19.868 EST: ISDN Se1/0:23 Q931: TX -> ALERTING pd = 8 callref = 0x8055

Progress Ind i = 0x8088 - In-band info or appropriate now available

Feb 7 2008 12:27:20.072 EST: ISDN Se1/0:23 Q931: TX -> CONNECT pd = 8 callref = 0x8055

Feb 7 2008 12:27:20.132 EST: ISDN Se1/0:23 Q931: RX <- CONNECT_ACK pd = 8 callref = 0x0055

Feb 7 2008 12:27:31.265 EST: ISDN Se1/0:23 Q931: RX <- DISCONNECT pd = 8 callref = 0x0055

Cause i = 0x8090 - Normal call clearing


Rajesh Revuru Thu, 02/07/2008 - 10:03
User Badges:
  • Silver, 250 points or more

Can you try selecting "Send Calling Name in Facility IE". Under your PRI configuration settings under Gateway.


PS: You have to reset your gateway to take these changes. Please plan accordingly


HTH

Paolo Bevilacqua Thu, 02/14/2008 - 12:35
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, there is no name of any sort in the setup message received. Complain to telco.

Actions

This Discussion