CCM6.01 2811 FXS port no dial tone off hook

Unanswered Question
Feb 9th, 2008
User Badges:

Using MGCP from CCM6.0 to a 2811 rtr with a 4 port FXS module. Analog phone goes off hook no dial tone. I can make calls to and from this port no problem at all but no dial tone off hook.


Anyone have any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Robert Salazar Sat, 02/09/2008 - 14:50
User Badges:
  • Cisco Employee,

Are these fxs port registered to callmanager?

'show ccm'

'show mgcp endpoints db'


You can try removing the mgcp dial-peers associated to one of the fxs ports, then take the phone off hook from that port and see if there's dialtone.

If so you may need to check the mgcp configuration.


If not do a 'show voice port summ' and check the status of these ports.


may want to enable debug vpm signal too when going offhook.

TODD BERGMAN Sun, 02/10/2008 - 13:37
User Badges:

Yes


Primary Registered 192.168.7.10

First Backup None

Second Backup None


Current active Call Manager: 192.168.7.10

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 21:35:42 UTC Feb 10 2008 (elapsed time: 00:00:13

)

Last MGCP traffic time: 21:35:42 UTC Feb 10 2008 (elapsed time: 00:00:13

)

Last failover time: None

Last switchback time: None

Switchback mode: Graceful

MGCP Fallback mode: Not Selected

Last MGCP Fallback start time: None

Last MGCP Fallback end time: None

MGCP Download Tones: Disabled


Configuration Auto-Download Information

=======================================

Current version-id: 1202678993-f0f0eb3c-73f7-449d-95fb-40f9c7d2c849

Last config-downloaded:00:00:00

Current state: Waiting for commands

Configuration Download statistics:

Download Attempted : 4

Download Successful : 4

Download Failed : 0

TFTP Download Failed : 12

Configuration Attempted : 4

Configuration Successful : 4

Configuration Failed(Parsing): 0

Configuration Failed(config) : 0

Last config download command: New Registration

FAX mode: cisco

Configuration Error History:


MESAVGW#sh mgcp endpoint db

Endpoint Name Type State NC Ext

aaln/S0/SU0/0 Analog Ready 0 192.168.7.10:2427 0 F

aaln/S0/SU0/1 Analog Ready 0 192.168.7.10:2427 0 F

aaln/S0/SU0/2 Analog Ready 0 192.168.7.10:2427 0 F

aaln/S0/SU0/3 Analog Ready 0 192.168.7.10:2427 0 F

aaln/S0/SU0/* SU NA 4 192.168.7.10:2427 0 F

aaln/S0/SU1/0 Analog Ready 0 192.168.7.10:2427 0 F

aaln/S0/SU1/* SU NA 1 192.168.7.10:2427 0 F

aaln/S0/SU*/* Slot NA 2 192.168.7.10:2427 0 F

aaln/S*/SU*/* AALN NA 1 192.168.7.10:2427 0 F

* Root NA 1 192.168.7.10:2427 0 F


0/1/0 is the FXS port I am testing with.


It's registered just when I make a call in either direction the phones ring but no audio or progress tones when off hook.

TODD BERGMAN Sun, 02/10/2008 - 14:03
User Badges:

Debug VPM signal going offhook onhook


*Feb 10 22:01:12.843: htsp_process_event: [0/1/0, FXSLS_ONHOOK, E_DSP_SIG_1100]f

xsls_onhook_offhook htsp_setup_ind

*Feb 10 22:01:12.843: [0/1/0] get_local_station_id calling num= calling name= ca

lling time=02/10 22:01 orig called=

*Feb 10 22:01:12.843: TGRM: reg_invoke_tgrm_accept_call(1, TGRM_CALL_VOICE, TGRM

_DIRECTION_IN, 0, 1, 0, 65535)

*Feb 10 22:01:12.843: TGRM: Calling vtsp_tsp_call_setup_ind().

*Feb 10 22:01:12.843: TGRM: reg_invoke_tgrm_call_update(0, 1, 0, 65535, 1, TGRM_

CALL_BUSY, TGRM_CALL_VOICE, TGRM_DIRECTION_IN)

*Feb 10 22:01:12.851: dsp_digit_collect_off: [0/1/0] packet_len=8 channel_id=133

packet_id=36htsp_connect: no_offhook 0 call_connected 0

*Feb 10 22:01:12.855: htsp_process_event: [0/1/0, FXSLS_WAIT_SETUP_ACK, E_HTSP_S

ETUP_ACK]fxsls_check_auto_call

*Feb 10 22:01:12.855: htsp_process_event: [0/1/0, FXSLS_OFFHOOK, E_HTSP_CONNECT]

fxsls_offhook_connect

*Feb 10 22:01:12.855: [0/1/0] set signal state = 0x6 timestamp = 0

*Feb 10 22:01:12.855: dsp_set_sig_state: [0/1/0] packet_len=12 channel_id=133 pa

cket_id=39 state=0x6 timestamp=0x0

*Feb 10 22:01:49.151: htsp_process_event: [0/1/0, FXSLS_CONNECT, E_DSP_SIG_0100]

fxsls_offhook_onhook, HF duration Max=1000, HF duration Min=150

*Feb 10 22:01:49.151: htsp_timer - 1000 msec

*Feb 10 22:01:50.151: htsp_process_event: [0/1/0, FXSLS_CONNECT, E_HTSP_EVENT_TI

MER]fxsls_connect_wait_release_req

*Feb 10 22:01:50.151: htsp_timer_stop

*Feb 10 22:01:50.151: htsp_timer_stop3 htsp_release_req: cause 16, no_onhook 0

*Feb 10 22:01:50.151: htsp_process_event: [0/1/0, FXSLS_WAIT_RELEASE_REQ, E_HTSP

_RELEASE_REQ]fxsls_waitrls_req_rls

*Feb 10 22:01:50.151: [0/1/0] set signal state = 0x4 timestamp = 0

*Feb 10 22:01:50.151: dsp_set_sig_state: [0/1/0] packet_len=12 channel_id=133 pa

cket_id=39 state=0x4 timestamp=0x0

*Feb 10 22:01:50.151: [0/1/0] set signal state = 0x4 timestamp = 0

*Feb 10 22:01:50.155: dsp_set_sig_state: [0/1/0] packet_len=12 channel_id=133 pa

cket_id=39 state=0x4 timestamp=0x0

*Feb 10 22:01:50.155: TGRM: reg_invoke_tgrm_call_update(0, 1, 0, 65535, 1, TGRM_

CALL_IDLE, TGRM_CALL_VOICE, TGRM_DIRECTION_IN)

*Feb 10 22:01:50.155: flex_dsprm_close_cleanuphtsp_allocate_if --


*Feb 10 22:01:50.163: HTSP endpoint_info=aaln/S0/SU1/0, type=2, under_specified

=0,

service_type=2htsp_allocate_if: MATCH!


*Feb 10 22:01:50.167: htsp_validate_cap

*Feb 10 22:01:50.167: flex_modem_relay_supported:Modem Relay supported. flex_typ

e=1

Robert Salazar Mon, 02/11/2008 - 07:47
User Badges:
  • Cisco Employee,

you may need to add the 'mgcp bind' commands to the gateway if you don't have it yet.



e.g.

conf t

mgcp bind media source-interface fa 0/0

no mgcp

mgcp



lordshawn Tue, 04/07/2009 - 05:25
User Badges:

I had the same problem. I deleted the lines from the MGCP config, then did a no mgcp mgcp...readded the lines...did no mgcp mgcp and it worked.

Actions

This Discussion