Problem with redistributing VRF routes into the global routing table.

Unanswered Question
Feb 10th, 2008

I'm trying to redistribute and OSPF vrf process into the global routing table and getting the following error:

"VRF specified does not match this router"

There are no other routers involved. And all subnets are public addresses.

I would have through that OSPF will go straight into BGP.

I also get the same error when trying to redistribut the OSPF routes into the BGP VRF instance.

ip vrf customer-public-vrf

rd 1111:1391

route-target export 1111:1391

route-target import 1111:1391


interface Loopback1391

ip vrf forwarding customer-public-vrf

ip address

mpls netflow egress


interface GigabitEthernet0/1.302

description Cust: customer-ethernet

ip vrf forwarding customer-public-vrf

ip address


router ospf 1391 vrf customer-public-vrf


redistribute static subnets

network area 0

distribute-list route-map customer-ethernet-OSPF-in in



router bgp 1111

address-family ipv4 vrf customer-public-vrf

redistribute connected

no auto-summary

no synchronization




ip route vrf sro-public-vrf


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
paul_alexander Sun, 02/10/2008 - 15:23

It still only lets me redistribute the process into the VRF address-family.

Not the global address-family.

Any thoughts?


This Discussion