New 2811 router

Answered Question
Feb 11th, 2008
User Badges:

I have a new router and I have already assigned a password, IP addresses on the fa0/1 and serial ports. Also put in a default-gateway so I can get to it. I'm trying to enable routing but when I do

router ospf 10 it comes back saying "IP routing not enabled" what am I missing here? I thought that is all I need to do to enable routing??

Correct Answer by Richard Burts about 9 years 2 months ago

Warren


I am glad that you got it worked out and that my suggestion was helpful. Thanks for the rating - the check would have been helpful so other people would recognize that it was resolved but it is not a big deal.


It is not entirely necessary to remove the default-gateway command. I will observe that I frequently configure routers with both the default route and the default-gateway command. As you discovered the default-gateway does not make any difference when ip routing is enabled. But every once in a while (especially if the router boots into rommon) you find the router operating as an IP host and the default-gateway can come in handy.


HTH


Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
wgranada1 Mon, 02/11/2008 - 06:52
User Badges:

Ok I found out why when I do router ospf I get

IP routing not enabled because I didn't enable routing. Next question is why when I enable ip routing I loose ip connectivity to the router?

Just a fyi I'm trying to build this router remotely from Chicago the router is in new york

and there is a default gateway that enables me to reach it via the ethernet port. Tried doing out of band connectivity but that didn't work.

arun kumar Mon, 02/11/2008 - 06:56
User Badges:
  • Bronze, 100 points or more

Hi,


You can try by enabling ip routing on globally in the router


router(config)#ip routing


HTH.. Pls use rating system



wgranada1 Mon, 02/11/2008 - 07:05
User Badges:


Yes I tried that but everytime I do that I lose IP connectivity to the router. I'm trying to build this router remotely, I'm here in chicago and the router is in ny. I can get to the router via the ethernet port and I have a default gateway configured as well which enables me to get to it. I tried to get to it via the out of band modem which is connected to the console port but that didn't work.

Richard Burts Mon, 02/11/2008 - 08:05
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Warren


The reason that you lose connectivity when you enable IP routing is that the ip default-gateway command which you indicate that you have configured works when the router is operating as an IP host (when ip routing is not enabled) but stops working when ip routing is enabled. So what you need to do is to configure a default route on the router before you enable ip routing.


I am not clear whether the router will accept an ip route command while ip routing is not enabled. If that is an issue then I would suggest that you create a text file on your PC and in that text file put the ip routing command and the ip route command. Then TFTP the text file to running-config of the router. That should get both commands into the router.


HTH


Rick

wgranada1 Mon, 02/11/2008 - 13:37
User Badges:

Thanks Rick that worked!!! I was able to put in


ip route 0.0.0.0 0.0.0.0 192.168.20.20


and then enable ip routing once I did that I still had connectivity to the router and I removed the default-gateway. So yeah I can configure routing now. Thank you again!!!!


Sorry forgot to check resolved my issue as it did...sorry about that

Correct Answer
Richard Burts Mon, 02/11/2008 - 13:45
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Warren


I am glad that you got it worked out and that my suggestion was helpful. Thanks for the rating - the check would have been helpful so other people would recognize that it was resolved but it is not a big deal.


It is not entirely necessary to remove the default-gateway command. I will observe that I frequently configure routers with both the default route and the default-gateway command. As you discovered the default-gateway does not make any difference when ip routing is enabled. But every once in a while (especially if the router boots into rommon) you find the router operating as an IP host and the default-gateway can come in handy.


HTH


Rick

wgranada1 Mon, 02/11/2008 - 13:49
User Badges:

That is a good point, maybe I will put it back

in just in case....thank you again for the info!!!

Actions

This Discussion