DHCP and WLC 4402 clients

Unanswered Question
Feb 11th, 2008

Hi

Our scenario is that we are building a test rig-up prior to WLC deployment. We have a 4402 WLC with LAP1242s, Windows clients. The WLC is running v4.2.99 firmware.

Our problem is that the wireless clients are not collecting DHCP addresses.

The configuration is:

Base network address is 172.31.4.0 / 255.255.252.0.

WLC on 172.31.7.220 / .221.

DHCP server on 172.31.4.12

G/W on 172.31.4.1.

We are simulating the gateway with an ADSL router (not connected so no external traffic but at the moment that is the least of our troubles), and the DHCP server with a Cisco 805 router with only the Ethernet interface in use (the 805 permits us to configure a different D/G to the DHCP server).

We have a catalyst 2950 switch in the circuit which has no VLANs nor access-lists configured.

The wireless clients can associate to the LWAPs but do not collect an IP address.

Wired clients can collect DHCP addresses and ping the DHCP, GW and controller.

Can anyone help me understand what is going on here please and how to get the DHCP working?

We did use this configuration - exactly these boxes in fact - to configure a different WLC last week (different subnets though) and we were successful - but not now.

Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Hmmm...

I've had issues with my 4402 controller not properly forwarding DHCP requests as well. I ended up having to use the DHCP server on the controller for the wireless, and a seperate DHCP server for the wired clients.

Do you have Smartnet? If so, open up a TAC request with Cisco and have them fix it. Please share the results with us. :)

nick-davies Wed, 02/13/2008 - 08:03

:-) I have done already...just waiting for the response.

This one has me tearing my hair out - all the settings *look* the same (different version levels permitting) as a 4404 controller, but there are some error in the msglog that I don't like the look of. Cisco have all the files.

nick-davies Thu, 02/14/2008 - 01:10

Do you still get this problem even with the latest firmware?

I've loaded 4.2.99 onto a brand-new controller, can't recall what it shipped with. I'm tempted to go back and try the 4.1.185 (?) release but I've got a TAC open on this as I said.

Scott Fella Thu, 02/14/2008 - 14:06

If you set a staic ip and associate to the ssid, can you ping and access anything?

nick-davies Mon, 02/18/2008 - 04:53

I finally went around the problem by installing 4.1.185 - now I don't know if that was the whole solution or if in reconfiguring it for the n-th time I changed something else: but I don't think so.

Anyway I ran out of time on this one: it works so it is going in.

Cisco TAC haven't come back to me yet :-(

Thanks to everyone who took the time to reply.

arunravi79 Wed, 02/20/2008 - 06:30

If the option 43 hex TLV is not set right, thogh the AP get's IP from DHCP, it won't reach the Controller.

nick-davies Wed, 02/20/2008 - 06:34

I see.

We are not using option 43 at all. The DHCP server is unchanged - the APs are using network broadcast to find the controller. As I posted above, the APs are contacting the controller without a problem, the clients are associating with the APs without a problem, only the clients weren't getting an IP adress.

The problem appeared to go away totally after I re-configured it with v4.1.185. It's in and working now so I won't be spending any more time on it.

While it would be interesting to try things out, these controllers are too expensive to have one lying around for long ;-)

Jacob-Harris Wed, 02/20/2008 - 18:30

Had a similiar issue with a guest SSID. We dropped off clients onto a vlan trunked to the controller which was segmented by a FWSM. Turns out controllers forward the DHCP request back to the client as broadcast v.s. unicast, and the FWSM didn't like that. Ended up configuring local DHCP on the controller for that 1 SSID.

m.hierling Sat, 03/15/2008 - 04:53

the wlc always acts as a dhcp relay agent. does your dhcp server accept such request?

I had such a setup with a asa acting as dhcp and gateway. but asa doenst anwser dhcp request comming from a relay agent. so perhaps check your dhcp servers log.

Martin

Actions

This Discussion