Do I need to remove static routes

Unanswered Question
Feb 11th, 2008
User Badges:

Currently between sites A and B we have

2 t1's configured toward each other via static routes


RouterA

A#sh ip int br

Interface IP-Address

FastEthernet0/0 192.168.21.236

(lan)


Serial0/0 192.168.100.253

(t1 link)


FastEthernet0/1 192.168.255.129

(wireless link)


Serial0/1 192.168.100.249

(t1 link)


ip route 192.168.2.0 255.255.255.0 192.168.100.254

ip route 192.168.2.0 255.255.255.0 192.168.100.250


router ospf 100

router-id 192.168.21.236

log-adjacency-changes

redistribute connected subnets

network 192.168.1.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 1

network 192.168.118.0 0.0.0.255 area 1

network 192.168.255.0 0.0.0.255 area 1



Router B


b#sh ip int br

FastEthernet1/1 192.168.255.130

(wireless link)


Serial1/0/0:0 192.168.100.254

(t1 link)


Serial1/0/1:0 192.168.100.250

(t1 link)


ip route 192.168.1.0 255.255.255.0 192.168.100.249

ip route 192.168.1.0 255.255.255.0 192.168.100.253


router ospf 100

log-adjacency-changes

redistribute connected subnets

redistribute bgp 62001 subnets

network 192.168.2.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 1

network 192.168.118.0 0.0.0.255 area 1

network 192.168.255.0 0.0.0.255 area 1


My question is...we are adding a third link btwn the two..routers..that is the 192.168.255.129 and .130 address you see.


We would like to use this third wireless link as the primary route btwn the two sites..and if this should fail...traffic should go back to the 2 t1's we currently have configured


My question is..You can see that we have

the t1's both in ospf and static configurations...will the static configs need to be removed so ospf can take over traffic priority?


We would configure the 2 t1's t that will now be used as failover..with a higher cost

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Mon, 02/11/2008 - 11:05
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

leonardo


If you reconfigure the static routes so that they have an administrative distance that is greater than the AD of OSPF then you could let OSPF select the primary route as the wireless. But if OSPF is running over the serial links then I do not see what value there is in having floating static routes since OSPF would be aware of the primary path over the wireless and the backup path over the T1s. What function would the static routes have for this?


One aspect of this question does puzzle me. The static routes are for 192.168.1.0 and 192.168.2.0 and I see that there are network statements under OSPF for these networks. But they do not show up in the show ip interface brief output. Where are these networks?


HTH


Rick

brooklynheight Mon, 02/11/2008 - 11:34
User Badges:

Hi Rick-



this is configured on router A


##sh run interface fastEthernet 0/0

interface FastEthernet0/0

ip address 192.168.1.236 255.255.255.0 secondary

ip address 192.168.21.236 255.255.255.0

no ip route-cache

speed 100



and this is on B


sh run


interface GigabitEthernet0/1

description Local LAN

ip address 192.168.2.236 255.255.255.0 secondary

ip address 192.168.2.245 255.255.255.0


from your viewpoint..is ospf not doing anything right now..since it looks like

routes are being chosen becuase of the static configuration?


Router A#sh ip route 192.168.2.0

Routing entry for 192.168.2.0/24

Known via "static", distance 1, metric 0

Routing Descriptor Blocks:

192.168.100.254

Route metric is 0, traffic share count is 1

* 192.168.100.250

Route metric is 0, traffic share count is 1




Router B #sh ip route 192.168.1.0

Routing entry for 192.168.1.0/24

Known via "static", distance 1, metric 0

Routing Descriptor Blocks:

192.168.100.253

Route metric is 0, traffic share count is 1

* 192.168.100.249

Route metric is 0, traffic share count is 1



Richard Burts Mon, 02/11/2008 - 12:23
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

leonardo


Clearly in the current configuration the path chosen is via the static routes. The default administrative distance of static routes is much better than the administrative distance of OSPF and so static routes will be preferred to OSPF routes.


If OSPF will be running over both T1 links and over the wireless link and if OSPF is advertising the LAN (192.168.1.0 or 192.168.2.0) over these links then I see no reason to have static routes or floating static routes.


However based on the partial configs posted I believe that there are some issues that need to be resolved. On router A there is clearly a primary subnet (192.168.21.0/24 and a secondary subnet 192.168.1.0/24). There is an OSPF network statement for the secondary network but not for the primary network. This is generally a problem. I would suggest adding a network statement for the primary network under router OSPF. On router B the primary network and the secondary network appear to be the same 192.168.2.0/24. Is this correct? If so why is there a secondary configured?


HTH


Rick

brooklynheight Mon, 02/11/2008 - 13:24
User Badges:

Hi Rick-


Correct..both the primary and secondary interfaces are in the same subnet on router B

192.168.2.0-and im not sure why there is a secondary


All users are on the 192.168.2.0 network at that site



Im not quite sure why router A has 2 different

.21 as the primary...



I did notice once when we were working this

that the wireless took over via ospf and

the preferred router to router B was the wireless link


however..when logged into router B..the preferred route to router A was still the

static routes over the t1's..so it

looked like we had 1 route one way..and another route back


is this becuase ospf is not advertising

the .1 network in router A as you pointed out?




Richard Burts Mon, 02/11/2008 - 13:40
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

leonardo


Without some more knowledge of the environment it is difficult to say for certain. But I believe it quite likely that OSPF was not advertising the .1 network and that lead to the asymetric route.


HTH


Rick

Actions

This Discussion