Need Assistence Configuring 2 Aironet 1310s as a Bridge

Unanswered Question
Feb 11th, 2008

I'm just starting to setup 2 1310s as a bridge for the first time. I've setup some basic settings through the web interface: IP settings on the BVIs, single SSID, and no security (yet). Also, I've set one as a root-bridge and the other as a non-root bridge. Things seem to look good so far on the root bridge, but when I try to enable the the dot11 interface on the non-root bridge, I keep getting the following message in the log:

%LINK-5-CHANGED: Interface Dot11Radio0, changed state to reset

%DOT11-4-CANT_ASSOC: Interface Dot11Radio0, cannot associate: No Response

I guess the first obvious question is: should I be able to establish a wireless signal without the external antennas? I don't have the external antennas yet, but my understanding is that I can establish a wireless signal without them as long as the 2 1310s are fairly close together; right now they are in my lab only a couple feet apart.

If my assumption is correct, what am I missing here?

Thanks,

Sean

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
dozinov01 Mon, 02/11/2008 - 16:36

Hey Sean,

The 1310's have built-in directional antennas. Make sure you have it set to use internal antennas and not external.

Once you verify that it is set to use the internal antennas, be sure to point them at each other and that the ssid's match on each side. (root and non-root)

Good luck,

Ryan

bcolvin Mon, 02/11/2008 - 21:04

Sean

It sounds like you have a configuration differance between the two 1310's.

Two things, first configure the root bridge, copy the configuration and use it to configure the 1310 designated as the non-root then change IP address to the non root static IP and the role from root bridge to non root bridgs and they will now be configured the same except for their role. Second separate them by 2-3ft with the TNC antenna connectors facing each other,not reccomended to run AP without antennas can dammage radio. Reccomended put a rubber duck antenna on each primary antenna connection and configure to use right or primary then they can be much further apart.

this is my normal proceedure for configuring and test before install

Bill

s-daly Tue, 02/12/2008 - 07:24

Thanks for the response, I do have the internal antennas enabled. Unfortunately, I don't have rubber duck antennas to work with, but it sounds like the internal antennas should work for testing. I also have the TNC connectors facing each other. I'm still getting the same error. Here, let me include the configurations, maybe someone will notice my mistake:

The root bridge:

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname mosj141wbr31

!

enable secret xxx

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

!

dot11 ssid mosj141lab

authentication open

infrastructure-ssid optional

!

!

!

username Cisco password xxx

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid mosj141lab

!

speed basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

station-role root bridge

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.16.1.53 255.255.255.224

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

The non-root bridge:

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname mosj141wbrlab1

!

enable secret xxx

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

!

dot11 ssid mosj141lab

authentication open

infrastructure-ssid optional

!

!

!

username Cisco password xxx

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid mosj141lab

!

speed basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

station-role non-root bridge

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.16.1.55 255.255.255.224

no ip route-cache

!

ip default-gateway 10.16.1.33

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

Thanks again for your responses.

bcolvin Tue, 02/12/2008 - 10:27

Sean

there are two models of the 1310 one with an internal antenna(AIR-BR1310G-X-K9AIR-BR1310G-X-K9) and one with remote antenna connections (AIR-BR1310G-X-K9-R) you have one or the other. As you have the RP-TNC connectors yours ar the later.

now back to the Config it looks pretty normal with the exception of the line that defines the speed you should only have 1.0 and 2.0 set to basic/required the remainder should only be set to enabled.

If the above doesn't fix you problem its time to go back to the basics. the default config, config each as an AP and check connection with a wireless client. then change roles to root and non-root and check for connection then make changes for security, VLAN's etc.

My reccomendation is to use the GUI to do the configuration do not use the CLI until you need to add something not covered by the GUI.

A;so no sure what the "resource policy" command is doing as it relies on assets on network.

good luck

Bill

Actions

This Discussion