Standby router in HSRP cluster respdonding to requests

Unanswered Question
Feb 12th, 2008

HSRP is functioning fine, however the standby router is responding to requets with an ip that is neither its own or the VIP of the HSRP group.

Is this normal behaviour?

LBC-YMQ-RTR-01#

.Feb 12 21:17:20.134: IP ARP: rcvd req src 172.30.4.4 0030.80ce.b061, dst 172.30.5.107 FastEthernet0/0

LBC-YMQ-RTR-02#

.Feb 12 21:17:21.158: IP ARP: rcvd req src 172.30.4.4 0030.80ce.b061, dst 172.30.5.107 FastEthernet0/0

.Feb 12 21:17:21.158: IP ARP: sent rep src 172.30.5.107 0000.0c07.ac0b,

dst 172.30.4.4 0030.80ce.b061 FastEthernet0/0

RTR01#nterface FastEthernet0/0

description LBC Customer Facing

ip address 172.30.4.7 255.255.255.0

ip access-group Fast0/0-in in

ip nat inside

ip route-cache flow

speed 10

full-duplex

standby 11 ip 172.30.4.9

standby 11 timers 2 4

standby 11 priority 115

standby 11 preempt

standby 11 track 100

RTR02#nterface FastEthernet0/0

description LBC Customer facing

ip address 172.30.4.8 255.255.255.0

ip access-group Fast0/0-in in

ip nat inside

ip route-cache flow

speed 10

full-duplex

standby 11 ip 172.30.4.9

standby 11 timers 2 4

standby 11 priority 110

standby 11 preempt

standby 11 track 100

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dnewell24 Tue, 02/12/2008 - 18:23

Not sure if this is normal behavior but it is possible. Is proxy-arp enabled on F0/0? Issue a show ip int fastethenet0/0. And if it is why?

Also why is host 172.30.4.4 ARPing for 172.30.5.107? Aren't these devices on different subnets? Looks like a misconfigured subnet mask on 172.30.4.4.

zac ragoonath Tue, 02/12/2008 - 18:26

I've turned off proxy arp tonight hoping this aleviates the issue. Yes they are on different subnets, the darndest this.

Anyway, thanks man, dont want to waste you guys' time.

Kevin Dorrell Wed, 02/13/2008 - 00:06

The HSRP should behave well even in the proxy ARP situation. Are you sure that RTR01 is the active one? I know it has higher seed priority, but what is the state of its "track 100"?

Because it seems to me that RTR02 is responding with the proxy ARP, but RTR01 is not. It might be interesting to compare their routes to the 172.30.5.0/24 subnet.

Kevin Dorrell

Luxembourg

Actions

This Discussion