Directory Number Issue

Unanswered Question
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
rob.huffman Wed, 02/13/2008 - 05:55

Hi Alistair,

Perhaps the second line has been assigned to an Internal-only Partition?

Hope this helps!


rob.huffman Wed, 02/13/2008 - 06:13

Hi Alistair,

Then maybe we could use this method to completely remove this second DN before trying again. Remove this DN from all phones first;

Can you please try this method via the Route Plan Report;

Deleting Unassigned Directory Numbers

This section describes how to delete an unassigned directory number from the route plan report. Directory numbers get configured and removed in the Directory Number Configuration window of Cisco CallManager Administration. When a directory number gets removed from a device or a phone gets deleted, the directory number still exists in the Cisco CallManager database. To delete the directory number from the database, use the Route Plan Report window.



Step 1 Choose Route Plan > Route Plan Report.

The Route Plan Report window displays. Use the three drop-down list boxes to specify a route plan report that lists all unassigned DNs.

Step 2 Three ways exist to delete directory numbers:

a. Click the directory number that you want to delete. When the Directory Number Configuration window displays, click Delete.

b. Check the check box next to the directory number that you want to delete. Click Delete Selected.

c. To delete all found unassigned directory numbers, click Delete all Found Items.

A warning message verifies that you want to delete the directory number.

Step 3 To delete the directory number, click OK. To cancel the delete request, click Cancel.

From this good doc;

Hope this helps!


rob.huffman Wed, 02/13/2008 - 06:49

Hi Alistair,

I was just thinking of removing any remnant info that may have been lurking around if this DN was ever used previously. Seen it happen before :)


rob.huffman Wed, 02/13/2008 - 07:27

Hi Alistair,

This sounds like a Telco/Provider problem to me. Is this a straight in DID Number?


egrinkin1 Wed, 02/13/2008 - 11:43

It's a 2nd appearance of the same DN?

Do you have that configuration on other devices?

I would try removing it, and programming a different DN if that's the case. The 2nd line could be a unique extension that the DID RNA or Hunts to.

~ Liz

rob.huffman Thu, 02/14/2008 - 03:47

Hi Alistair,

If when you call Externally you say you got an "Out of Service" message, is this a recording? If so, this is not being played from within the CCM itself. Have you contacted the Telco? It does sound like a problem that is not config related.

Let us know,


egrinkin1 Thu, 02/14/2008 - 04:39

How about trying this?

1. Remove the 2nd line and replace with a non-DID extension.

2.Set up the first line to fna and hunt to the 2nd

You'll still get the same result, but avoid the 2nd DID error treatment.

rob.huffman Thu, 02/14/2008 - 05:38

Hi Alistair,

I like Liz's idea (5 points for this Liz :) but I'm still curious about this exact issue. Have you tried putting this number on its own IP Phone (Line 1). Plus I'm not sure if you ever did completely remove everything about this DN and start over (my appologies if I've missed something).

I have had problems in the past with only 1 number out of a whole DID range, so it's not out of the question.



This Discussion