Conferencing issue

Answered Question
Feb 13th, 2008

We have CCM 4.1(3) in Greece, it dials out via an H323 gateway which is enabled on a 2811 series router, IOS version - 12.3(11)T2.

Problem - Internal conferencing works fine, but international conferencing doesn't. Suppose someone outside the cluster calls from US to Greece, the call is setup & then if the user wants to join another caller, say from Britian on a con call it doesn't work. Can something be done about this, I mean enabling off-cluster conferencing?

I have this problem too.
0 votes
Correct Answer by davetucker about 8 years 9 months ago

No problems,

Yes!

dial-peer voice x voice

voice class codec 10

That way it will try G.711 first instead of G789r8 which is the default codec for a voip dial-peer.

Regards,

Dave

Correct Answer by davetucker about 8 years 9 months ago

Abhijit,

When a PSTN Call Terminates on a gateway, a VoIP leg is established between the gateway and the IP phone and therefore a codec is negotiated.

The negotiaited codec depends on the region settings in Call Manager, in this scenario we need to use G.711. Ideally the Phone, Gateway and the Conference Bridge should be in the same Region(and that Region should be configured to use G.711 for calls within region).

If they are not you will configure your regions so that G.711 is used between these regions for the conference to work.

Hope this helps,

Regards,

Dave

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.9 (8 ratings)
Loading.
davetucker Wed, 02/13/2008 - 07:40

Hi,

It sounds like you don't have any conference bridges or MTPs available to the gateway.

Assign a Media Resource Group List to the gateway, or the device pool to which your gateway belongs that contains a MRG with your Confernece Bridges.

Check out the following section of the admin guide. http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/admin/4_1_3/ccmsys/a05confb.html

Hope this helps, if so please rate.

Regards,

Dave

UCBNOCWAN Wed, 02/13/2008 - 23:23

Hi Dave,

Thanks a lot for your reply. I checked the config & found that there is no hardware conference bridge configured, only a software conf bridge exists. There are no transcoders. The user's phone is not assigned to any MRGL. ( by default it should take the software bridge I guess). The software bridge is assigned to the Gateway & also the relevant Device pool. Not sure what's the problem here.

davetucker Thu, 02/14/2008 - 02:20

Hi,

Just looking at this another way...

The phones will not be able to initiate an Ad-Hoc conference if they have no CFB in their MRGL. It may be worth adding the MRGL with the Software CFB to the Phones or their device pool.

Just be aware that there are is a Service Parameters regarding Ad-Hoc Conferencing.

Step 1 From Cisco CallManager Administration, choose Service > Service Parameter.

Step 2 From the Server drop-down list box, choose a server in the cluster.

Step 3 From the Service drop-down list box, choose Cisco CallManager.

Step 4 From the Drop Ad Hoc Conference drop-down list box, choose one of the following options:

•Never-The conference is not dropped. (This is the default option.)

•When No OnNet Parties Remain in the Conference-The system drops the active conference when the last on-network party in the conference hangs up or drops out of the conference. Cisco CallManager releases all resources that are assigned to the conference. the conference hangs up or drops

•When Conference Creator Drops Out-The active conference terminates when the primary controller (conference creator) hangs up. Cisco CallManager releases all resources that are assigned to the conference.

Hope this helps, If so please rate.

Regards,

Dave

UCBNOCWAN Thu, 02/14/2008 - 05:54

Dear Dave,

Thanks again. Just one thing though - for off-net parties to join an ad-hoc con-call, will software bridge suffice? Think it should.

Wish you a very happy V-day.

Regards,

Abhijit Das.

davetucker Thu, 02/14/2008 - 06:37

Abhijit,

Software CFB should suffice for off-net parties to join an ad-hoc conf call.

With software conferencing you can have up to 128 streams, so 1 conference with 128 users, or 42 conferences with 3 users per conference etc.. If you require more than this, I would invest in some DSP resource!

Thanks for the ratings.

Regards,

Dave

UCBNOCWAN Thu, 02/14/2008 - 06:42

Dave,

Thanks again. Will enabling MTP on the gateway make any difference, even though we are not using that Gateway as a DSP resource? I don't think it will, just wanna confirm it from you.

Thanks & Regards,

Abhijit Das.

UCBNOCWAN Thu, 02/14/2008 - 06:31

Dear Dave,

Spoke with the customer right now, this is exactly what is happening :

Customer is in Greece, Suppose someone outside the cluster calls him, he is able to receive the call. He then makes an off-cluster call & connects to the 2nd caller by placing the 1st call on hold. He can see both calls simultaneously. The moment he tries to have a 3-party con-call, the phone displays - " cannot complete conference". Is this due to lack of Conferencing resources? Thanks a lot for your patience.

davetucker Thu, 02/14/2008 - 06:42

HI,

Symptom

Cisco Unified IP Phone displays the message: "Unable to complete conference call" or "Cannot complete conference call."

Possible Cause

This could indicate a codec mismatch exists between IP phones used for conferencing.

Recommended Action

Do one of the following:

-Use the same codecs on phones used for conferencing, and make sure that all of the regions and conference bridges use the same codec.

-Use hardware conference bridges which can perform transcoding.

This could be a possible mismatch in codecs.

Software CFBs only support G.711 and cannot perform transcoding.

Hope this helps.

Regards,

Dave

UCBNOCWAN Thu, 02/14/2008 - 06:51

Thanks Dave,

just to be more specific, all the IP phones involved in the call are not IP phones, only the customer in Athens is using an IP phone, all the rest are PSTN phones. Will codec mismatch make any difference to that ? Sorry that I forgot to mention that PSTN phones are involved earlier.

Regaards,

Abhijit Das.

Correct Answer
davetucker Thu, 02/14/2008 - 07:01

Abhijit,

When a PSTN Call Terminates on a gateway, a VoIP leg is established between the gateway and the IP phone and therefore a codec is negotiated.

The negotiaited codec depends on the region settings in Call Manager, in this scenario we need to use G.711. Ideally the Phone, Gateway and the Conference Bridge should be in the same Region(and that Region should be configured to use G.711 for calls within region).

If they are not you will configure your regions so that G.711 is used between these regions for the conference to work.

Hope this helps,

Regards,

Dave

rob.huffman Thu, 02/14/2008 - 08:41

Hi Abhijit,

Just thought that I would add a set of eyes to the great help from Dave. This sounds like a training issue as well; Here is your clip

"Spoke with the customer right now, this is exactly what is happening :

Customer is in Greece, Suppose someone outside the cluster calls him, he is able to receive the call. He then makes an off-cluster call & connects to the 2nd caller by placing the 1st call on hold. He can see both calls simultaneously. The moment he tries to have a 3-party con-call, the phone displays - " cannot complete conference". Is this due to lack of Conferencing resources? "

This is not how to accomplish an AdHoc Conference call. The user would need to take the 1st call then Press the Conf Softkey Dial the 2nd call and Press the Conf Softkey a second time. Then all 3 parties will be connected. The Hold Button will not be involved.

If the call has been placed already then the User would have to use the Join Softkey.

Hope this helps my friend!

Rob

UCBNOCWAN Thu, 02/14/2008 - 22:52

Hi Rob,

Nice to hear from you again!

I had entertained the possibility that the customer is trying to invoke ad-hoc conferencing in an improper manner. I got an update that he is able to initiate ad-hoc conferencing fine when only on-net parties are involved. He faces issues only when off-net parties try to join in. Hence for the moment, I am ruling out the probability of the customer doing something wrong.

Have a nice day & thanks for your assistance. This will surely help me to educate my customers on initiating ad-hoc conferencing in a simple way instead of having to explain again & again.

Thanks & Regards,

Abhijit Das.

UCBNOCWAN Thu, 02/14/2008 - 22:41

Dave,

Thanks again for this info. Now I think I have a clear picture of what is required.

This is the scenario :

The customer is using G729 within their region, I have not seen G711 anywhere in the CCM.

The phones, Gateway & Conference Bridge ( software) are all in the same region.

The region has been configured to use G729 even within the region.

The Gateway is not used as a conference resource since I see the following command:

voice-card 0

no dspfarm

My analysis is I need to do the following things :

Configure the "Region" settings to use G711 within the region.

Add these commands to the gateway ( currently no codec has been configured on the Gateway) :

voice class codec 10

codec preference 1 g711alaw

codec preference 2 g711ulaw

Think this should resolve the issue. Kindly suggest if anything else needs to be done. Sincere thanks again.

Abhijit.

davetucker Fri, 02/15/2008 - 01:47

Abhijit,

Exactly!

Just remember to assign the voice class codec to the dial-peer, also add g729r8 as preference 3 just to cover yourself.

The key to this is making sure everything is talking G.711 because then the software CFBs should work nicely.

Let me know how it goes,

Regards,

Dave

UCBNOCWAN Fri, 02/15/2008 - 02:17

Thanks Dave, so I guess under the voip dial-peer I need to add " voice class codec 10 " to make sure everything is fine.

Correct Answer
davetucker Fri, 02/15/2008 - 02:28

No problems,

Yes!

dial-peer voice x voice

voice class codec 10

That way it will try G.711 first instead of G789r8 which is the default codec for a voip dial-peer.

Regards,

Dave

UCBNOCWAN Fri, 02/15/2008 - 02:59

Thanks Dave,

Greatly appreciate the fact that you took so much time out of your busy schedule to help me out. Thanks & have a nice day & great weekend.

Thanks & Regards,

Abhijit Das.

UCBNOCWAN Fri, 02/15/2008 - 06:02

Dave, just one final thing regarding this issue - we don't have any transcoders configured anywhere. Think that should not make any difference here. Just wanted to double-check with you.

Regards,

Abhijit Das.

Actions

This Discussion