How to restrict inbound calls to shared line appearance when busy

Unanswered Question

We have a somewhat odd scenario that I've been struggling with trying to resolve on my own. We have Call Manager 4.1(3) deployed in a very loud manufacturing plant environment. . They can't hear the phone ring near their equipment. Their old phone system (Nortel) had an analog strobe light/bell attached to the phone which was programmed to "also ring at..." that line/extension. So when their phone rang, this combination loud buzzer/horn and strobe light also rang. They picked up the phone.., everything is fine. It was perfect.

So along I come with Cisco Call Manager & IP Phones and I'm trying to replicate this behavior. It's necessary in our loud environment, since they simply DON'T hear the ringer built-into the IP phones.

Given SRST considerations, etc., I opted to implement using shared line appearance. Using a single extension (Directory Number) on both their 7906 IP phone, and the analog Strobe Light/Buzzer device attached to an FXS port in a voice gateway...

When a call comes in, the buzzer rings, the IP Phone rings.., they answer.., the buzzer stops... everything is fine.


When they are on a call, and a second call comes in, the buzzer rings indefinitely because it's got the same DN associated with the "desk" IP phone.., but there is no way to answer the call! Even though I have MAX 1 call set on both devices, Call Manager technically sees the shared line appearance associated with the "Buzzer (FXS analog port)" as a "free" device with that DN.. , thus ringing it.

Ultimately what I'm trying to do is get the IP phone to have a companion "ringer" that can be a loud buzzer/bell/horn + strobe light to help them hear their phone in a loud environment. I thought using shared lines was my only option..., while setting the max calls to 1. But now I'm stuck because I can't seem to limit the MAX number of calls to the DN (across ANY/multiple shared device(s)). I only want 1 call to be supported for the DN.., across ALL devices using that DN.

Sorry if this is confusing. I'm doing my best to explain.

If anyone has accomplished this using a different technique, or can suggest something else to try, I'd greatly appreciate it !

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
rob.huffman Wed, 02/13/2008 - 16:37

Hi Peter,

Have you played with the "Busy Trigger" setting at all? I would think that this would be the play here not Max Calls. Try setting the Busy Trigger to 1.

Hope this helps!



This Discussion